summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/piklab
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/piklab')
-rw-r--r--dev-util/piklab/Manifest1
-rw-r--r--dev-util/piklab/metadata.xml11
-rw-r--r--dev-util/piklab/piklab-0.16.2.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/piklab/Manifest b/dev-util/piklab/Manifest
new file mode 100644
index 000000000000..9561c5a45f86
--- /dev/null
+++ b/dev-util/piklab/Manifest
@@ -0,0 +1 @@
+DIST piklab-0.16.2.tar.bz2 1036644 SHA256 51de9edda8edb9d2e9d07ed1c479b83b87eb6fb17c85717477f05fac03a5740e SHA512 8fdf8fdbcedbb0c7b840341575560e6bc3d02b5564cecd043fbe0e1bf6560aa28bd1e92ed2c80ea6d890bb5759dd0d4a72571f68ab7ee0858eb98649097e5f30 WHIRLPOOL be037be4fbf410cb9722d2a20a3b96222f57d63f0a4d7e744b65bd53937a73d3576aa6be80d16f8b478c3fdeb0663964a74be8344678b65adbe0af669eec42ab
diff --git a/dev-util/piklab/metadata.xml b/dev-util/piklab/metadata.xml
new file mode 100644
index 000000000000..b930de0e48fc
--- /dev/null
+++ b/dev-util/piklab/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">piklab</remote-id>
+ <bugs-to>http://sourceforge.net/tracker/?group_id=138852</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/piklab/piklab-0.16.2.ebuild b/dev-util/piklab/piklab-0.16.2.ebuild
new file mode 100644
index 000000000000..429f8296ae22
--- /dev/null
+++ b/dev-util/piklab/piklab-0.16.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+KDE_REQUIRED="optional"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="de cs es fr hu it"
+inherit kde4-base
+
+DESCRIPTION="IDE for applications based on PIC and dsPIC microcontrollers"
+HOMEPAGE="http://piklab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qt3support:4
+ sys-libs/readline
+ virtual/libusb:0
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( Changelog README TODO )
+
+src_prepare() {
+ sed -e "/install(FILES README/d" \
+ -i CMakeLists.txt || die
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use !kde QT_ONLY)
+ -DLOCALE_INSTALL_DIR="/usr/share/locale"
+ )
+ kde4-base_src_configure
+}