summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-26 02:59:21 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-26 03:00:54 -0700
commiteab314dd418fcb14105b0f54e33d6d5b6c1eb0d0 (patch)
treef66527263463547da5d54715a10eabd753b565b5 /dev-util/pkgcheck/pkgcheck-0.7.5.ebuild
parentsys-apps/pkgcore: version bump to 0.10.11 (diff)
downloadgentoo-eab314dd418fcb14105b0f54e33d6d5b6c1eb0d0.tar.gz
gentoo-eab314dd418fcb14105b0f54e33d6d5b6c1eb0d0.tar.bz2
gentoo-eab314dd418fcb14105b0f54e33d6d5b6c1eb0d0.zip
dev-util/pkgcheck: version bump to 0.7.5
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-0.7.5.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.7.5.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-0.7.5.ebuild b/dev-util/pkgcheck/pkgcheck-0.7.5.ebuild
new file mode 100644
index 000000000000..61ffc645f69f
--- /dev/null
+++ b/dev-util/pkgcheck/pkgcheck-0.7.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="pkgcore-based QA utility for ebuild repos"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="network perl test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="
+ ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
+ ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND="
+ >=dev-python/snakeoil-0.8.7[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.10.11[${PYTHON_USEDEP}]"
+fi
+RDEPEND+="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pathspec[${PYTHON_USEDEP}]
+ network? ( dev-python/requests[${PYTHON_USEDEP}] )
+ perl? ( dev-perl/Gentoo-PerlMod-Version )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}