summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-26 16:58:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-26 16:58:06 +0200
commit616d91d8da0398e1fffd9955c016f644d9cd45c3 (patch)
tree4a73a876d3ea224e12ae66bf23f19b760858139b /dev-util/pkgconf
parentdev-util/pkgconf: Added new EGIT_REPO_URI and HOMEPAGE to live ebuild (diff)
downloadgentoo-616d91d8da0398e1fffd9955c016f644d9cd45c3.tar.gz
gentoo-616d91d8da0398e1fffd9955c016f644d9cd45c3.tar.bz2
gentoo-616d91d8da0398e1fffd9955c016f644d9cd45c3.zip
dev-util/pkgconf: Bump to version 1.6.3
Closes: https://bugs.gentoo.org/687548 Closes: https://bugs.gentoo.org/690752 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-1.6.3.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index 8f779ca2d77a..2811e3f6a863 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1,2 +1,3 @@
DIST pkgconf-1.3.7.tar.xz 271840 BLAKE2B f4bb44e92ef2903a5962c85e0d4a939adf035c5e92fbd1d8a50d4022507d1f442e459849b537cc2b648c7a1bb5eac33aabf8a46d8b0df8794514596adee9888d SHA512 6c06afc4fe64c94a833db98d4dc7881192d38cc28eb1fb86345f4ce065489930ac953aa9f6b2df172127244cb1cbab1c85a042aa0f6be4fa18bf9dcd83173960
DIST pkgconf-1.5.4.tar.xz 290380 BLAKE2B 8353901e9fe86f05abc82c5906b24ec902086f5c9a08ffdc9f6d53ecdebcf7c52eb9bbaef019285332182ca8f489cfe872f25bfe110e280031a553331df09bcb SHA512 795a67f8f98b7598c0af8e70c830851561f090a96cb66b75149e5faf633f06c1b098fa3cec76cde35160a9809556536da6a2a95af8ff954c9b28536d15b79f93
+DIST pkgconf-1.6.3.tar.xz 291216 BLAKE2B 04bf58590e2f0b37bac7b24b3d595ad08680e85647548cbd642495398d95706f9f738af5c6f9b9ad8801567caa20ade85d4c4d74179f08313420683cb1b34263 SHA512 437c5a5c9866e2047e62e0592639930b2420d4afd41d98cef51f3475165418a39e916477860025314828a6ee0a4eefc10fdf26bda66f80c291f324d9674fa5c1
diff --git a/dev-util/pkgconf/pkgconf-1.6.3.ebuild b/dev-util/pkgconf/pkgconf-1.6.3.ebuild
new file mode 100644
index 000000000000..64b29db65e5b
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-1.6.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2012-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ #EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ EGIT_REPO_URI="https://git.dereferenced.org/${PN}/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="http://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://git.dereferenced.org/pkgconf/pkgconf/"
+
+LICENSE="ISC"
+SLOT="0/3"
+IUSE="+pkg-config test"
+
+# tests require 'kyua'
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+RDEPEND="
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
+src_prepare() {
+ default
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_test() {
+ unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
+ default
+}
+
+multilib_src_install() {
+ default
+
+ if use pkg-config; then
+ dosym pkgconf /usr/bin/pkg-config
+ dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
+ else
+ rm "${ED}"/usr/share/aclocal/pkg.m4 || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}