summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-11 17:01:33 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-11 17:01:33 +0200
commit33ad8e064436feb536ceafd7da36a06ecb9cae49 (patch)
treeb85564c3349c9fb364f455be2b0425a406eb94d9 /dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r2.ebuild
parentnet-p2p/deluge: Use GLEP 81 for user/group instead of user eclass (diff)
downloadgentoo-33ad8e064436feb536ceafd7da36a06ecb9cae49.tar.gz
gentoo-33ad8e064436feb536ceafd7da36a06ecb9cae49.tar.bz2
gentoo-33ad8e064436feb536ceafd7da36a06ecb9cae49.zip
dev-util/pkgconfig-openbsd: Remove last-rited pkg
Closes: https://bugs.gentoo.org/694034 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r2.ebuild')
-rw-r--r--dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r2.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r2.ebuild b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r2.ebuild
deleted file mode 100644
index e47abefe3039..000000000000
--- a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507-r2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PERL_EXPORT_PHASE_FUNCTIONS=no
-inherit eutils multilib perl-module multilib-minimal
-
-# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config
-
-PKG_M4_VERSION=0.28
-
-DESCRIPTION="A perl based version of pkg-config from OpenBSD"
-HOMEPAGE="http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/usr.bin/pkg-config/"
-SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz
- pkg-config? ( https://pkgconfig.freedesktop.org/releases/pkg-config-${PKG_M4_VERSION}.tar.gz )"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+pkg-config"
-
-RDEPEND="virtual/perl-Getopt-Long
- pkg-config? (
- !dev-util/pkgconfig
- !dev-util/pkgconf[pkg-config]
- )"
-
-S=${WORKDIR}/src
-
-src_prepare() {
- epatch_user
- ecvs_clean
-
- epatch "${FILESDIR}/${P}-zap-warning.patch"
-
- # Config.pm from dev-lang/perl doesn't set ARCH, only archname
- sed -i -e '/Config/s:ARCH:archname:' usr.bin/pkg-config/pkg-config || die
-
- if use pkg-config; then
- MULTILIB_CHOST_TOOLS=( /usr/bin/pkg-config )
- else
- MULTILIB_CHOST_TOOLS=( /usr/bin/pkg-config-openbsd )
- fi
-}
-
-multilib_src_install() {
- local pc_bin=pkg-config
- use pkg-config || pc_bin+=-openbsd
-
- newbin "${S}"/usr.bin/pkg-config/pkg-config ${pc_bin}
- newman "${S}"/usr.bin/pkg-config/pkg-config.1 ${pc_bin}.1
-
- # insert proper paths
- local pc_paths=(
- /usr/$(get_libdir)/pkgconfig
- /usr/share/pkgconfig
- )
- sed -i -e "/my @PKGPATH/,/;/{s@(.*@( ${pc_paths[*]} );@p;d}" \
- "${ED%/}/usr/bin/${pc_bin}" || die
-}
-
-multilib_src_install_all() {
- if use pkg-config; then
- insinto /usr/share/aclocal
- doins "${WORKDIR}"/pkg-config-*/pkg.m4
- fi
-
- perl_set_version
- insinto "${VENDOR_LIB}"
- doins -r "${S}"/usr.bin/pkg-config/OpenBSD
-}