summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/pmk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/pmk')
-rw-r--r--dev-util/pmk/Manifest1
-rw-r--r--dev-util/pmk/metadata.xml15
-rw-r--r--dev-util/pmk/pmk-0.10.4.ebuild61
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/pmk/Manifest b/dev-util/pmk/Manifest
new file mode 100644
index 000000000000..b308be60711a
--- /dev/null
+++ b/dev-util/pmk/Manifest
@@ -0,0 +1 @@
+DIST pmk-0.10.4.tar.gz 208475 SHA256 bde39a1fb1f0612446838f4845f44f1a0a2adb9c62c2d0f9e3ca58c61888a569 SHA512 906ee690b6cae55d54b1e248847a61ddcb15d7404fb8914040047876eb906f868607b38b59dbbd9687a0f8b409d6c3852249d558119af1bea4c64775f34ea32d WHIRLPOOL 9f4c8295b53c3fe9cdbb56fa927ef05bdef7b36e8852af46ea362ba738283eaab69d5e486edcab654e0650f11339ad3ba25216b6e219531c678d6c166b8fe914
diff --git a/dev-util/pmk/metadata.xml b/dev-util/pmk/metadata.xml
new file mode 100644
index 000000000000..7ec158b4a32a
--- /dev/null
+++ b/dev-util/pmk/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ The meaning of pmk is "Pre Make Kit", a dependency configuring tool. It
+ aims to be considered as an alternative to GNU autoconf, GNU libtool
+ and pkg-config.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pmk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/pmk/pmk-0.10.4.ebuild b/dev-util/pmk/pmk-0.10.4.ebuild
new file mode 100644
index 000000000000..6dc47dc8c7f6
--- /dev/null
+++ b/dev-util/pmk/pmk-0.10.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs
+
+DESCRIPTION="Aims to be an alternative to GNU autoconf"
+HOMEPAGE="http://pmk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # Make this respect LDFLAGS, bug #334987
+ sed -i -e "s:CLDFLAGS:LDFLAGS:" Makefile.pmk || die
+ sed -i -e "/@CLDFLAGS@/d" Makefile.pmk || die
+
+ # Remove executable stack
+ cp detect_cpu_asm.s detect_cpu_asm.S
+ cat >> detect_cpu_asm.S <<EOF
+#ifdef __ELF__
+.section .note.GNU-stack,"",%progbits
+#endif
+EOF
+}
+
+src_configure() {
+ tc-export CC CPP AS
+ export SYSCONFDIR="${EPREFIX}"/etc
+ export PREFIX="${EPREFIX}"/usr
+ ./pmkcfg.sh autodetected || die "Config failed"
+}
+
+src_install () {
+ emake -j1 DESTDIR="${D}" MANDIR="${EPREFIX}/usr/share/man" install || die "make failed"
+
+ dodoc BUGS Changelog README STATUS TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if [[ ! -f ${EROOT}etc/pmk/pmk.conf ]] ; then
+ einfo
+ einfo "${EROOT}etc/pmk/pmk.conf doesn't exist."
+ einfo "Running pmksetup to generate an initial pmk.conf."
+ einfo
+ # create one with initial values
+ "${EROOT}"usr/bin/pmksetup
+ # run it again to reset PREFIX from /usr/local to ${EPREFIX}/usr
+ "${EROOT}"usr/bin/pmksetup -u "PREFIX=\"${EPREFIX}/usr\""
+ # remove the automatically created backup from the extra run
+ rm -f "${EROOT}"etc/pmk/pmk.conf.bak
+ fi
+}