summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-17 08:11:02 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-17 08:11:35 +0200
commit88d4dcde6d861a93ee5efe103433fdd5fbd21aa8 (patch)
treef0f6e16f54e1a26e72f540623658f03b5fbb2767 /dev-util/protobuf-cucumber
parentdev-util/cucumber-cucumber-expressions: add 10.3.0 (diff)
downloadgentoo-88d4dcde6d861a93ee5efe103433fdd5fbd21aa8.tar.gz
gentoo-88d4dcde6d861a93ee5efe103433fdd5fbd21aa8.tar.bz2
gentoo-88d4dcde6d861a93ee5efe103433fdd5fbd21aa8.zip
dev-util/protobuf-cucumber: initial import of 3.10.8
Dependency for forthcoming cucumber-messages version. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-util/protobuf-cucumber')
-rw-r--r--dev-util/protobuf-cucumber/Manifest1
-rw-r--r--dev-util/protobuf-cucumber/metadata.xml10
-rw-r--r--dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild35
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/protobuf-cucumber/Manifest b/dev-util/protobuf-cucumber/Manifest
new file mode 100644
index 000000000000..5f3d93032b9d
--- /dev/null
+++ b/dev-util/protobuf-cucumber/Manifest
@@ -0,0 +1 @@
+DIST protobuf-cucumber-3.10.8.gem 236544 BLAKE2B e81636fc06fbed54dc67def3d4d1c445a971d861e3dcd99aa406e137b858734d995100c76d33a6d00b6ec9584d8dbb8f1d05424e73d0f35a3d196cfb70ffc561 SHA512 904b3b6f0564a9db61c1b8e3aef10fe666dd602cf09c43c32241e908695b2f144be5e9ee094a21a07c43354ecaa3c9006ff62aa0e6f6ad2688b72bb9a40538a9
diff --git a/dev-util/protobuf-cucumber/metadata.xml b/dev-util/protobuf-cucumber/metadata.xml
new file mode 100644
index 000000000000..31246c7969b9
--- /dev/null
+++ b/dev-util/protobuf-cucumber/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>graaff@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby-protobuf/protobuf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild b/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild
new file mode 100644
index 000000000000..1d4dbac95549
--- /dev/null
+++ b/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Google Protocol Buffers serialization and RPC implementation for Ruby"
+HOMEPAGE="https://github.com/ruby-protobuf/protobuf"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ >=dev-ruby/activesupport-3.2:*
+ dev-ruby/middleware
+ dev-ruby/thor:*
+ dev-ruby/thread_safe
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile spec/spec_helper.rb || die
+
+ # Avoid unpackaged optional dependency
+ rm -f spec/lib/protobuf/rpc/connectors/{ping,zmq}_spec.rb spec/functional/zmq_server_spec.rb || die
+ rm -rf spec/lib/protobuf/rpc/servers/zmq || die
+ sed -i -e '/context .zmq/,/^ end/ s:^:#:' spec/lib/protobuf/cli_spec.rb || die
+}