summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-16 23:48:00 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-10-16 23:48:00 +0200
commit822d4bdac89ddced6b4cdf31e691aea1c24c6a80 (patch)
treeea36567f83e204da587d2c095c2ac459cba018da /dev-util/pycharm-community/pycharm-community-2016.2.3.ebuild
parentdev-util/pycharm-professional: Version bump to 2016.2.3 (diff)
downloadgentoo-822d4bdac89ddced6b4cdf31e691aea1c24c6a80.tar.gz
gentoo-822d4bdac89ddced6b4cdf31e691aea1c24c6a80.tar.bz2
gentoo-822d4bdac89ddced6b4cdf31e691aea1c24c6a80.zip
dev-util/pycharm-community: Version bump to 2016.2.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util/pycharm-community/pycharm-community-2016.2.3.ebuild')
-rw-r--r--dev-util/pycharm-community/pycharm-community-2016.2.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/pycharm-community-2016.2.3.ebuild b/dev-util/pycharm-community/pycharm-community-2016.2.3.ebuild
new file mode 100644
index 000000000000..233c50990d3d
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2016.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/${PN}/bin/fsnotifier
+ /opt/${PN}/bin/fsnotifier64"
+
+MY_PN=${PN/-community/}
+
+QA_PREBUILT="*"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_create_doc
+}