summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-12-06 21:26:52 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-12-06 21:28:58 +0300
commitdba455c1e55df39a6222aa50d0122bc087545c33 (patch)
tree02c3877027399a98a48681e0ac0c4dd803fbd685 /dev-util/pycharm-community/pycharm-community-2018.3.1.ebuild
parentgnome-extra/gnome-color-manager: fix package name sed to actually work (diff)
downloadgentoo-dba455c1e55df39a6222aa50d0122bc087545c33.tar.gz
gentoo-dba455c1e55df39a6222aa50d0122bc087545c33.tar.bz2
gentoo-dba455c1e55df39a6222aa50d0122bc087545c33.zip
dev-util/pycharm-community: Version bump (v2018.3.1)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-util/pycharm-community/pycharm-community-2018.3.1.ebuild')
-rw-r--r--dev-util/pycharm-community/pycharm-community-2018.3.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/pycharm-community-2018.3.1.ebuild b/dev-util/pycharm-community/pycharm-community-2018.3.1.ebuild
new file mode 100644
index 000000000000..7a0fdedacc6e
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2018.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}