summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-01-25 17:58:14 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-01-25 17:58:14 +0300
commit78e4a7384fca3ae9b8a95572789e55e05cad275c (patch)
tree2c863654d3ad3e2963133411e2d4f2aee6c6a085 /dev-util/pycharm-community/pycharm-community-2019.3.2.ebuild
parentapp-crypt/p11-kit: Drop old (diff)
downloadgentoo-78e4a7384fca3ae9b8a95572789e55e05cad275c.tar.gz
gentoo-78e4a7384fca3ae9b8a95572789e55e05cad275c.tar.bz2
gentoo-78e4a7384fca3ae9b8a95572789e55e05cad275c.zip
dev-util/pycharm-community: Version bump (v2019.3.2)
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-util/pycharm-community/pycharm-community-2019.3.2.ebuild')
-rw-r--r--dev-util/pycharm-community/pycharm-community-2019.3.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/pycharm-community-2019.3.2.ebuild b/dev-util/pycharm-community/pycharm-community-2019.3.2.ebuild
new file mode 100644
index 000000000000..0600c9803a8d
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2019.3.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-libs/libdbusmenu
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}