summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcklaucke <33376323+cklaucke@users.noreply.github.com>2018-01-01 13:18:21 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-26 22:22:16 +0100
commitb584dff1d626f78c0adae21a56cef3413452f4fd (patch)
tree60a3a414d6ba60828c1608c26e149d6da927a26f /dev-util/pycharm-community
parentsys-fs/udev: amd64 stable wrt bug #645076 (diff)
downloadgentoo-b584dff1d626f78c0adae21a56cef3413452f4fd.tar.gz
gentoo-b584dff1d626f78c0adae21a56cef3413452f4fd.tar.bz2
gentoo-b584dff1d626f78c0adae21a56cef3413452f4fd.zip
dev-util/pycharm-community: version bump to 2017.3.3.
Bug: https://bugs.gentoo.org/642948 Closes: https://github.com/gentoo/gentoo/pull/6707
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2017.3.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index d3c6b94ee6dc..61305e0f1bcd 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,2 +1,3 @@
DIST pycharm-community-2017.3.1.tar.gz 279798932 BLAKE2B e442ffb2445915a14408a7a7221bfd256a4ca13a654db91dad5f267304fff666238b624c0448ff80b620bb73b2839093d7df678745715feba49941907030024a SHA512 0fe8a80751954e9cd9b6cae63e16b75f22095cddd784f9adfe1073ee62ec1aecf8f60ba2c332a575e70f2c0d312150f8d5129a9d1c539b541ccc6b0b8a37961a
+DIST pycharm-community-2017.3.3.tar.gz 279677180 BLAKE2B 373276332c918a325290e9ca0fa37ac7512025e0c0ee8149c3c08321b0477a0a5263fc24dece443c471f2a96a1b147153b0952466e374acf62389e1c49a1f114 SHA512 d4e9dffa7d2abef825fdbe7ce2665e2d249b18d81f7dab5051a0a2fda7896e5df7cce16e19518225dd23205c346df8fc5c5b3cb39280886004340cba60aeacd4
DIST pycharm-community-2017.3.tar.gz 282451011 BLAKE2B 250265d7cb0cb3ba94733c9404f6bc1c6e4f62207721011e9eec65780f9e4c92148626065051a1e875124d013cff488c8d7ab9861c094bf4a33c0b8596e717e9 SHA512 4e835f671971171966f52a4219f47fda2675b2fcf38f0f91ff90b1aa00508ed3b5445a488750c6e9d82515780e9f190201da918230c0b80d869d6b16ab352cc6
diff --git a/dev-util/pycharm-community/pycharm-community-2017.3.3.ebuild b/dev-util/pycharm-community/pycharm-community-2017.3.3.ebuild
new file mode 100644
index 000000000000..4cba69da5984
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2017.3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}