summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-03-21 11:40:14 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-03-21 11:40:47 +0300
commitd1311110faf6e8f78abb4174824bb9c70b481660 (patch)
tree93d6adeab197787085a2955254716c54894da2f4 /dev-util/pycharm-community
parentx11-misc/xscreensaver: Old (diff)
downloadgentoo-d1311110faf6e8f78abb4174824bb9c70b481660.tar.gz
gentoo-d1311110faf6e8f78abb4174824bb9c70b481660.tar.bz2
gentoo-d1311110faf6e8f78abb4174824bb9c70b481660.zip
dev-util/pycharm-community: Version bump (v2019.3.4)
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2019.3.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index 225b62a07135..a46d84913820 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,3 +1,4 @@
DIST pycharm-community-2019.3.1.tar.gz 389620376 BLAKE2B a780ab27feef9747539d9cd607b67c7e047d0a7c1eb6b090a63c4f1c11c80c49e5091a29d80ea249ace1f16acdcd418f0a4901e10c2c623e792da9d7d0e7c9d6 SHA512 4bfa78a5f3993e85ad5ba624ed9e586d195b9f4bffa8bd764e8dba27edc1cdc0bd2b3bba86135156c1f306601db290703e61e7561badc7dcb634dc5826134b1f
DIST pycharm-community-2019.3.2.tar.gz 391689310 BLAKE2B 11627839e823e2d6c946f5fa25df28cb919960300c51dcc2883989341228604dad9ebf365ffc055809bf3768d757b40cb059a7b5cc492935733c5576ff3f9933 SHA512 6c9e607d938a23be78b4acb5aa39e6276720347aac6fadfbaf456e4f05af4b55ef24f4a97f3aca91b6f09d68af7ec834a5af5e08b775d1439d573cff6c6d3e7c
DIST pycharm-community-2019.3.3.tar.gz 391606138 BLAKE2B a07bf941ea7a98cadf6ff15b8f69e745ceecf0a820a098811d462a638b0d1b749e1580e23f0cfbdb78a9740e0f41777dd7d505527b6bc83f9c9d5e9ff70a6c95 SHA512 566667109662cffeaba6da9b5e5837adb00f8fbb29523f8415d4fd691cb71f7a40952d28c3713c0409ecbf50ce116ef83bf34a4cbe46015a2a11593771dc97a9
+DIST pycharm-community-2019.3.4.tar.gz 391698063 BLAKE2B f089515412a769c7ffb88cd30aab43def64ff66a0d59ced35740efac4d604220fa5d293d8eb65eea0fc35c116f9d5f771f50f38fc1e61329507cd62070e39ad8 SHA512 0cb5684816eb739de5d106ab8262c9004914d174e89210866286841512c1aa80c00af4299c72f31c1da59c4ed92da10f423c9d5c37e53e1fe836f0586da30c6e
diff --git a/dev-util/pycharm-community/pycharm-community-2019.3.4.ebuild b/dev-util/pycharm-community/pycharm-community-2019.3.4.ebuild
new file mode 100644
index 000000000000..0600c9803a8d
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2019.3.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-libs/libdbusmenu
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}