summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2017-04-12 10:25:46 -0400
committerMike Pagano <mpagano@gentoo.org>2017-04-12 10:25:46 -0400
commit4cb505e26e6f2823c5f707770b851714df939b07 (patch)
tree68dd5a970947b4e276c3cdf8793ac89b51f7d0eb /dev-util/quilt
parentmail-mta/opensmtpd: revbump to fix libressl and musl (diff)
downloadgentoo-4cb505e26e6f2823c5f707770b851714df939b07.tar.gz
gentoo-4cb505e26e6f2823c5f707770b851714df939b07.tar.bz2
gentoo-4cb505e26e6f2823c5f707770b851714df939b07.zip
dev-util/quilt: Version bump. Tests now working closing bug #316893. Thanks to mjo for discovering and reporting.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/quilt')
-rw-r--r--dev-util/quilt/Manifest1
-rw-r--r--dev-util/quilt/files/quilt-0.65-no-graphviz.patch43
-rw-r--r--dev-util/quilt/quilt-0.65.ebuild61
3 files changed, 105 insertions, 0 deletions
diff --git a/dev-util/quilt/Manifest b/dev-util/quilt/Manifest
index abda92426a20..6735e6ec42b9 100644
--- a/dev-util/quilt/Manifest
+++ b/dev-util/quilt/Manifest
@@ -1,2 +1,3 @@
DIST quilt-0.50.tar.gz 452769 SHA256 fa4579628a98cf94472b36869e74f5cd0cb057d6fd13c1872a53f01c45aba8c3 SHA512 c6258872bc591b35e93ba09cc17b4954696faf391aff71b7789cc8cc58c4c54e51b605896937bd1aa54545eed6bf1e9b70352ad9b643f869154e6953c0340365 WHIRLPOOL d4823f9c1507fc3b29f605df855c53343bc0e0b300617b8203d9422d3fede2e1930ba9390329b3ee484fbeb7dde5535f9938c84ceee63477eb8fc0c705556822
DIST quilt-0.63.tar.gz 389593 SHA256 2846788221aa8844c54f10239c7cbc5e88031859162bcc285449446c3cfffe52 SHA512 e6d5c601805b664a5586a557799e7b321b6b28f7ccec708f52aa96371c987e5791aa54418c9b89d34154e4967ddfe7a261e37195fd29b6aa529e8fa6e5007c45 WHIRLPOOL 89b72f38d75e479fc8f030398757ab325ab46ff79baa7227fe122c4902d582374971c8c5f562611f0c024e8b56db01858669cd0427338f2368492ff118f31280
+DIST quilt-0.65.tar.gz 410780 SHA256 f6cbc788e5cbbb381a3c6eab5b9efce67c776a8662a7795c7432fd27aa096819 SHA512 37dffe34fe209371f2fbc0af2dbb4dcfa6edd2221aed15f31a0651a0bd457f2af03a98450a3e63406f70e040e944246e5b23733b820665eeb3fd4ff2bdde3a08 WHIRLPOOL 533a355a690ff598caea35ac94d00822baf225b5bb59705ed2cf3d484a1db55068dd7d0ab1ccaedef403b1d0c2c3369037bbd04839899eba46b3ea516fbae4ae
diff --git a/dev-util/quilt/files/quilt-0.65-no-graphviz.patch b/dev-util/quilt/files/quilt-0.65-no-graphviz.patch
new file mode 100644
index 000000000000..ea06a9eebefb
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.65-no-graphviz.patch
@@ -0,0 +1,43 @@
+--- Makefile.in.orig 2017-04-12 09:27:40.853018901 -0400
++++ Makefile.in 2017-04-12 09:36:16.584315529 -0400
+@@ -78,8 +78,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns inspect-wrapper dependency-graph edmail \
+- remove-trailing-ws backup-files
++SCRIPTS_IN := patchfns inspect-wrapper edmail remove-trailing-ws backup-files
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+--- bash_completion.orig 2017-04-12 09:27:57.643126246 -0400
++++ bash_completion 2017-04-12 09:30:27.673938451 -0400
+@@ -28,7 +28,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied upgrade'
+
+@@ -122,19 +122,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt --quiltrc - applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ type _longopt &> /dev/null && _longopt grep
+ COMPREPLY=( "${COMPREPLY[@]}" $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/quilt-0.65.ebuild b/dev-util/quilt/quilt-0.65.ebuild
new file mode 100644
index 000000000000..40ccf8926d5c
--- /dev/null
+++ b/dev-util/quilt/quilt-0.65.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="quilt patch manager"
+HOMEPAGE="https://savannah.nongnu.org/projects/quilt"
+SRC_URI="https://savannah.nongnu.org/download/quilt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE="emacs graphviz elibc_Darwin elibc_SunOS"
+
+RDEPEND="sys-apps/ed
+ dev-util/diffstat
+ graphviz? ( media-gfx/graphviz )
+ elibc_Darwin? ( app-misc/getopt )
+ elibc_SunOS? ( app-misc/getopt )
+ >=sys-apps/coreutils-8.5"
+
+PDEPEND="emacs? ( app-emacs/quilt-el )"
+
+pkg_setup() {
+ use graphviz && return 0
+ echo
+ elog "If you intend to use the folding functionality (graphical illustration of the"
+ elog "patch stack) then you'll need to remerge this package with USE=graphviz."
+ echo
+}
+
+src_prepare() {
+
+ # Add support for USE=graphviz
+ use graphviz || epatch "${FILESDIR}/${P}-no-graphviz.patch"
+}
+
+src_configure() {
+ local myconf=""
+ [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] && \
+ myconf="${myconf} --with-getopt=${EPREFIX}/usr/bin/getopt-long"
+ econf ${myconf}
+}
+
+src_install() {
+ emake BUILD_ROOT="${D}" install || die "make install failed"
+
+ rm -rf "${ED}"/usr/share/doc/${P}
+ dodoc AUTHORS TODO doc/README doc/README.MAIL doc/quilt.pdf
+
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp bash_completion ${PN}
+
+ # Remove the compat symlinks
+ rm -rf "${ED}"/usr/share/quilt/compat
+
+ # Remove Emacs mode; newer version is in app-emacs/quilt-el, bug 247500
+ rm -rf "${ED}"/usr/share/emacs
+}