summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-08-02 20:23:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-08-02 20:28:39 +0100
commitc65333de6b4a81b7b6901e4c2e38b647d501a3d4 (patch)
tree78af09ebefe9f35b43fa65c5be5338821cc341d1 /dev-util/re2c
parentsys-apps/systemd: add cgroup-hybrid USE flag (diff)
downloadgentoo-c65333de6b4a81b7b6901e4c2e38b647d501a3d4.tar.gz
gentoo-c65333de6b4a81b7b6901e4c2e38b647d501a3d4.tar.bz2
gentoo-c65333de6b4a81b7b6901e4c2e38b647d501a3d4.zip
dev-util/re2c: bump up to 1.2
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/re2c')
-rw-r--r--dev-util/re2c/Manifest1
-rw-r--r--dev-util/re2c/re2c-1.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/re2c/Manifest b/dev-util/re2c/Manifest
index a0ecb1f0961a..fd2602eb3dcb 100644
--- a/dev-util/re2c/Manifest
+++ b/dev-util/re2c/Manifest
@@ -1 +1,2 @@
DIST re2c-1.1.1.tar.gz 5907416 BLAKE2B da2544573de0dbca94db8a8e2112de5549ffbbad91bdba187e95c9d8dd36537e099dbc2871b54d62630d91928cdaf384ab069e5e1624f8ff749c2e2743cff766 SHA512 a6fe73611103588043748340976f0e6d07169a6546cb80627c0ccd2ceac83f362dbbf371530361d893537fd95deb19503b2c73c41ed40efe7787210d6c757397
+DIST re2c-1.2.tar.xz 2064236 BLAKE2B ebc721de4fe1588a3043bb05298324b61214e074154ebc2adff19c6e5a3cc6a94314216a20020e88069d89768c31ae5c3f09b18176cd241d7aa10aa7b2daf183 SHA512 d029abc3493a26761eaa911cf73961f5b8ec2e00958c97740e73f568fc72b02b5f56d80e09657a95dcf2e7767f3e5085775bb78f0f5bc472d506682a3a7fc278
diff --git a/dev-util/re2c/re2c-1.2.ebuild b/dev-util/re2c/re2c-1.2.ebuild
new file mode 100644
index 000000000000..20575ddeb6fd
--- /dev/null
+++ b/dev-util/re2c/re2c-1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.org/"
+SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+src_configure() {
+ econf \
+ ac_cv_path_BISON="no" \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r README.md CHANGELOG examples
+}