summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2017-01-20 22:34:31 +0100
committerDirkjan Ochtman <djc@gentoo.org>2017-01-20 22:34:31 +0100
commit1c7cd46a23418502cb4a9170067a24cb4e098f5e (patch)
tree9bab211c039ad7a227910f82c0074ffcbec21293 /dev-util/rebar/rebar-2.6.3.ebuild
parentwww-apache/mod_wsgi: remove old versions (diff)
downloadgentoo-1c7cd46a23418502cb4a9170067a24cb4e098f5e.tar.gz
gentoo-1c7cd46a23418502cb4a9170067a24cb4e098f5e.tar.bz2
gentoo-1c7cd46a23418502cb4a9170067a24cb4e098f5e.zip
dev-util/rebar: version bump to 2.6.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/rebar/rebar-2.6.3.ebuild')
-rw-r--r--dev-util/rebar/rebar-2.6.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/rebar/rebar-2.6.3.ebuild b/dev-util/rebar/rebar-2.6.3.ebuild
new file mode 100644
index 000000000000..bc8437bccf43
--- /dev/null
+++ b/dev-util/rebar/rebar-2.6.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/rebar/rebar"
+SRC_URI="https://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}