summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/rec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/rec')
-rw-r--r--dev-util/rec/Manifest1
-rw-r--r--dev-util/rec/metadata.xml7
-rw-r--r--dev-util/rec/rec-1.6.ebuild54
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/rec/Manifest b/dev-util/rec/Manifest
new file mode 100644
index 000000000000..72c54ac1b5b8
--- /dev/null
+++ b/dev-util/rec/Manifest
@@ -0,0 +1 @@
+DIST rec16lx.zip 311993 SHA256 3f8f4c802b33352fe0114bbf7758d4f5510b3e435824539cf8b5a73eb0162a87 SHA512 180f17cedb76ac3474b6d23da648eee9efba13c0c7288759c624032aafdb6d49832b4059a2b96421c88d8138c5aba28a3b352e479963eea1c031e6df3d159271 WHIRLPOOL 9fe3fbe68f0bc9e175eea338bd8b0db5fc54703c39adc36030437db6f61e9a4734101d67b94ac60e65d2c8c1e8c15160960df64b4bb88c70b774bd04151e68a5
diff --git a/dev-util/rec/metadata.xml b/dev-util/rec/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-util/rec/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/rec/rec-1.6.ebuild b/dev-util/rec/rec-1.6.ebuild
new file mode 100644
index 000000000000..1e251390cc0c
--- /dev/null
+++ b/dev-util/rec/rec-1.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Reverse Engineering Compiler"
+HOMEPAGE="http://www.backerstreet.com/rec/rec.htm"
+SRC_URI="http://www.backerstreet.com/rec/rec16lx.zip"
+
+LICENSE="BSD-2 free-noncomm HPND"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RESTRICT="strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/gpm"
+
+S=${WORKDIR}
+
+QA_PREBUILT="/opt/bin/rec"
+
+src_unpack() {
+ unzip -L -d "${S}" -q "${DISTDIR}/${A}" || die
+}
+
+src_prepare() {
+ sed -i 's#\(^.*$\)#/opt/rec/\1#g' proto.lst || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodir /opt/rec
+ into /opt
+ dobin rec
+
+ insinto /opt/rec
+ doins proto.lst
+ doins string.o stdio.o stdlib.o fcntl.o winbase.o winuser.o wingdi.o
+ dodoc readme copyrite
+}
+
+pkg_postinst() {
+ elog "/opt/rec/proto.lst should be copied into the working"
+ elog "directory of new projects, this will make rec aware of common"
+ elog "prototypes."
+}