summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-03-02 08:53:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-03-02 08:53:57 +0000
commit5900b992a552550f9137ecceefa3e35a679ae352 (patch)
treea26b3863f435e488e9bb020d0774f68bf9ae2497 /dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild
parentdev-libs/rocr-runtime: Fix version detection (diff)
downloadgentoo-5900b992a552550f9137ecceefa3e35a679ae352.tar.gz
gentoo-5900b992a552550f9137ecceefa3e35a679ae352.tar.bz2
gentoo-5900b992a552550f9137ecceefa3e35a679ae352.zip
dev-util/rocm_bandwidth_test: add 5.4.3
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild')
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild
new file mode 100644
index 000000000000..684546f46011
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-rocm-${PV}"
+
+src_install() {
+ cmake_src_install
+
+ rm -rfv "${ED}"/usr/share/doc/rocm-bandwidth-test
+}