summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2021-03-28 17:39:03 +0200
committerCraig Andrews <candrews@gentoo.org>2021-03-28 17:20:27 -0400
commit2ee2bfe903a7a335a285d1f1860829683fc155ba (patch)
tree5955e5b24d017570ab5aa57fba5500d5442b7e9d /dev-util/rocminfo/rocminfo-4.1.0.ebuild
parentdev-libs/rocr-runtime: Version bump to 4.1.0 (diff)
downloadgentoo-2ee2bfe903a7a335a285d1f1860829683fc155ba.tar.gz
gentoo-2ee2bfe903a7a335a285d1f1860829683fc155ba.tar.bz2
gentoo-2ee2bfe903a7a335a285d1f1860829683fc155ba.zip
dev-util/rocminfo: Version bump to 4.1.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/rocminfo/rocminfo-4.1.0.ebuild')
-rw-r--r--dev-util/rocminfo/rocminfo-4.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/rocminfo/rocminfo-4.1.0.ebuild b/dev-util/rocminfo/rocminfo-4.1.0.ebuild
new file mode 100644
index 000000000000..a4b4217d09b1
--- /dev/null
+++ b/dev-util/rocminfo/rocminfo-4.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/rocminfo-rocm-${PV}"
+fi
+
+DESCRIPTION="ROCm Application for Reporting System Info"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocr-runtime-${PV}"
+DEPEND="${RDEPEND}"