summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-17 13:25:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-17 13:25:11 +0200
commita5a6f6d8c5686a71a9cd8e81e0897e8bf3e0b5aa (patch)
tree982f8512a4aba86a70d0582eab5c68568ef442e4 /dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
parentdev-util/rosinstall: initial import. ebuild by me. (diff)
downloadgentoo-a5a6f6d8c5686a71a9cd8e81e0897e8bf3e0b5aa.tar.gz
gentoo-a5a6f6d8c5686a71a9cd8e81e0897e8bf3e0b5aa.tar.bz2
gentoo-a5a6f6d8c5686a71a9cd8e81e0897e8bf3e0b5aa.zip
dev-util/rosinstall_generator: initial import. ebuild by me.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild')
-rw-r--r--dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
new file mode 100644
index 000000000000..608b89cd0fba
--- /dev/null
+++ b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosinstall_generator"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Generates rosinstall files containing information about repositories with ROS packages/stacks"
+HOMEPAGE="http://wiki.ros.org/rosinstall_generator"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosinstall_generator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/catkin_pkg-0.1.28[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"