summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-03-10 21:00:40 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-14 14:06:54 +0200
commit16eff8a8af396d68ea860b715095b85592c9d3c4 (patch)
tree4c5f7f38ce66c8cf79ee03fc1fa801ea51aa1b59 /dev-util/rt-tests/rt-tests-1.8.ebuild
parentmail-filter/rspamd: add licenses of bundled libraries (diff)
downloadgentoo-16eff8a8af396d68ea860b715095b85592c9d3c4.tar.gz
gentoo-16eff8a8af396d68ea860b715095b85592c9d3c4.tar.bz2
gentoo-16eff8a8af396d68ea860b715095b85592c9d3c4.zip
dev-util/rt-tests: Bump to version v1.8
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/rt-tests/rt-tests-1.8.ebuild')
-rw-r--r--dev-util/rt-tests/rt-tests-1.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/rt-tests/rt-tests-1.8.ebuild b/dev-util/rt-tests/rt-tests-1.8.ebuild
new file mode 100644
index 000000000000..b0d1f73bce71
--- /dev/null
+++ b/dev-util/rt-tests/rt-tests-1.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8})
+
+inherit python-single-r1
+
+DESCRIPTION="A collection of latency testing tools for the linux(-rt) kernel"
+HOMEPAGE="https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git/about/"
+SRC_URI="
+ https://kernel.org/pub/linux/utils/rt-tests/${P}.tar.xz
+ https://kernel.org/pub/linux/utils/rt-tests/older/${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ sys-process/numactl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake prefix=/usr DESTDIR="${D}" MAN_COMPRESSION=none install
+ python_fix_shebang "${ED}"
+ python_optimize
+}