summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-03 16:08:18 +0000
committerSam James <sam@gentoo.org>2020-12-03 16:09:07 +0000
commite23ac57b262128facbe9c07af83de9badf78caae (patch)
treeffc1c812f75b02cb5fef9e994b88aef47093fde7 /dev-util/scanmem/scanmem-0.17.ebuild
parentsys-process/bcron: Add Python 3.8, 3.9 (diff)
downloadgentoo-e23ac57b262128facbe9c07af83de9badf78caae.tar.gz
gentoo-e23ac57b262128facbe9c07af83de9badf78caae.tar.bz2
gentoo-e23ac57b262128facbe9c07af83de9badf78caae.zip
dev-util/scanmem: Add Python 3.8, 3.9
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/scanmem/scanmem-0.17.ebuild')
-rw-r--r--dev-util/scanmem/scanmem-0.17.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/scanmem/scanmem-0.17.ebuild b/dev-util/scanmem/scanmem-0.17.ebuild
index 2c502521ae88..9fd46852bf87 100644
--- a/dev-util/scanmem/scanmem-0.17.ebuild
+++ b/dev-util/scanmem/scanmem-0.17.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-inherit autotools eutils python-single-r1
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit autotools python-single-r1
DESCRIPTION="Locate and modify variables in executing processes"
HOMEPAGE="https://github.com/scanmem/scanmem"
@@ -54,5 +55,6 @@ src_install() {
dodoc gui/{README,TODO}
python_fix_shebang "${ED}"
fi
+
find "${ED}" -type f -name "*.la" -delete || die
}