summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-16 23:50:54 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-16 23:59:33 -0700
commite3f794ddeea898242061b21c8f81f9e5edb96de4 (patch)
tree4993c13ca384149fd6cd29a2df46d23863398cca /dev-util/schroot
parentdev-lang/spidermonkey: fix compiling 102.2.0 with rust-1.63 (diff)
downloadgentoo-e3f794ddeea898242061b21c8f81f9e5edb96de4.tar.gz
gentoo-e3f794ddeea898242061b21c8f81f9e5edb96de4.tar.bz2
gentoo-e3f794ddeea898242061b21c8f81f9e5edb96de4.zip
dev-util/schroot: add 1.6.13_p2, switch to reschroot
debian kept the name, so do we Closes: https://bugs.gentoo.org/869977 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/schroot')
-rw-r--r--dev-util/schroot/Manifest2
-rw-r--r--dev-util/schroot/schroot-1.6.13_p2.ebuild148
2 files changed, 150 insertions, 0 deletions
diff --git a/dev-util/schroot/Manifest b/dev-util/schroot/Manifest
index 85b6be19abae..39950ce75357 100644
--- a/dev-util/schroot/Manifest
+++ b/dev-util/schroot/Manifest
@@ -1,3 +1,5 @@
+DIST schroot-1.6.13.tar.gz 687581 BLAKE2B 5054407e545f39258df7598dbc233a836f6a86a02b4d0f3368109fd3edaea543fde6f81cfc6fedcdd6124490a3d5bc4d3a7e113ebe5ba2cfe7ec2c204f9cd0f4 SHA512 a250a02eb2384f1c27a9ff6479b77647a7a19b96b3b4e9d63e32a5dabe6ef3a3b1e2efaf98ddd9db93ded50fc93595ce545b0f0247c4a9e481349adafe806c2d
DIST schroot_1.6.10-12.debian.tar.xz 83636 BLAKE2B 0289848f7e64983c06f47a70346e06d7024722c643034ac24745fe4548311b893053ec28891f39264cb0894c12236f4e8523b70cd83553d1a7179cbfc63cbfa3 SHA512 77ae2d758593de505e9381e4800eb17a9e14fb949a5bdb07b9235671ae4bd18c668aa9c35a1ba6340af93b308b5c3798afc83f14165e4b19e7cebab92b83fc52
DIST schroot_1.6.10-7.debian.tar.xz 82524 BLAKE2B 664ee356f8de1215c761a771cc0700d25ff6c0513124f4d84d5b33a046cac6ff194b62dded1e8f966a922a013644edd3d9424b0d577a8bb2b371e23e8dd88ed5 SHA512 ee362cce46ec804cd0ad6bfe3c7dec37fdeffe56941d51aec9e9622057a4d2a94e47f7530d28862c948233c6623cfa4b4721c27f293e31a28ec0320ffe02a47a
DIST schroot_1.6.10.orig.tar.xz 797328 BLAKE2B 1f91531f22c5b0a75e5bb74effc660efe4819acc59b007355c12a01c0a1de12674881dd0fbbcab00575a02629662fca799d48f5b967eb527812ed8c08ff9ad28 SHA512 25155989c7811ab4c7bf3cdceaa8d0ffb12f08388143891def96fcd205f1cc401dad9a74f0e9a9ef8610d50174ff8319a8368401431dc87e1a11c0241e61fcbe
+DIST schroot_1.6.13-2.debian.tar.xz 110752 BLAKE2B 77c877e13541968ffd4edaa04c1a846e9deb19a3670088c19cdf3a217acfc2521d2b8d8dec7b8e6188b107f793af6152d5724fd596a9c62f6c9b57f2c30d57b0 SHA512 8fd7e7f95131285ec49bda3d9ccc6ba025976009c382998ef183142d2e3e288b7936e2c8ec6532870b601f62b460d577920d9a801b789f0d1bf7ee31b45356c3
diff --git a/dev-util/schroot/schroot-1.6.13_p2.ebuild b/dev-util/schroot/schroot-1.6.13_p2.ebuild
new file mode 100644
index 000000000000..1633e2829da1
--- /dev/null
+++ b/dev-util/schroot/schroot-1.6.13_p2.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 cmake pam tmpfiles
+
+MY_P=${PN}_${PV/_p/-}
+
+DESCRIPTION="Utility to execute commands in a chroot environment"
+HOMEPAGE="https://codeberg.org/shelter/reschroot"
+SRC_URI="https://codeberg.org/shelter/reschroot/archive/release/re${P/%_p*}.tar.gz -> ${P/%_p*}.tar.gz
+ mirror://debian/pool/main/${PN::1}/${PN}/${MY_P}.debian.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+IUSE="btrfs +dchroot debug doc lvm nls pam test zfs"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/boost:=
+ >=sys-apps/util-linux-2.16
+ btrfs? ( >=sys-fs/btrfs-progs-0.19-r2 )
+ lvm? ( sys-fs/lvm2 )
+ pam? ( sys-libs/pam )
+ zfs? ( sys-fs/zfs )
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ sys-apps/groff
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ nls? (
+ >=app-text/po4a-0.40
+ sys-devel/gettext
+ )
+ test? ( >=dev-util/cppunit-1.10.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/debianutils
+ dchroot? ( !sys-apps/dchroot )
+ nls? ( virtual/libintl )
+"
+
+S="${WORKDIR}/re${PN}"
+
+src_unpack() {
+ unpack "${P/%_p*}".tar.gz
+ cd "${S}"
+ unpack ${MY_P}.debian.tar.xz
+}
+
+src_prepare() {
+ sed -i -e 's/warn(/message(WARNING /' man/CMakeLists.txt || die
+ eapply "${S}"/debian/patches/*.patch
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Dbtrfs-snapshot=$(usex btrfs)
+ -Ddchroot=$(usex dchroot)
+ -Ddchroot-dsa=$(usex dchroot)
+ -Ddebug=$(usex debug)
+ -Ddoxygen=$(usex doc)
+ -Dlvm-snapshot=$(usex lvm)
+ -Dnls=$(usex nls)
+ -Dpam=$(usex pam)
+ -Dtest=$(usex test)
+ -Dzfs-snapshot=$(usex zfs)
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ -DCMAKE_INSTALL_LOCALSTATEDIR="${EPREFIX}/var"
+ -DSCHROOT_MOUNT_DIR="${EPREFIX}/run/${PN}/mount"
+ -DBoost_NO_BOOST_CMAKE=ON # https://bugs.gentoo.org/791712 and https://bugs.gentoo.org/752120
+ )
+ if ! use nls; then
+ mycmakeargs+=(-DPO4A_EXECUTABLE=NOTFOUND)
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile all $(usev doc)
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]]; then
+ ewarn "Disabling tests because you are not root"
+ return 0
+ fi
+ # -j1 to prevent race between test/setup-test-data and test/cleanup-test-data
+ cmake_src_test -j1
+}
+
+src_install() {
+ cmake_src_install
+
+ # debian-stype PS1 for chroot
+ # checks for /etc/debian_chroot file, which is created by schroot
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}/schroot_prompt.sh"
+
+ # gentoo /var/tmp/portage handler
+ # e.g. portage.base.tmpdir=/var/tmp/portage in config file
+ # will use a subdirectory of hosts $PORTAGE_TMPDIR
+ exeinto /etc/schroot/setup.d
+ doexe "${FILESDIR}/11gentoo"
+
+ # support for zfs clone options.
+ # zfs.clone.options=com.sun:auto-snapshot=false
+ if use zfs; then
+ exeinto /etc/schroot/setup.d
+ doexe "${FILESDIR}/06zfscloneopts"
+ fi
+
+ keepdir /var/lib/schroot/{session,unpack,union/{overlay,underlay}}
+
+ docinto contrib/setup.d
+ dodoc contrib/setup.d/05customdir contrib/setup.d/09fsck contrib/setup.d/10mount-ssh
+
+ newdoc debian/schroot.NEWS NEWS.debian
+
+ newinitd "${FILESDIR}"/schroot.initd schroot
+ newconfd "${FILESDIR}"/schroot.confd schroot
+ newtmpfiles "${FILESDIR}"/schroot.tmpfilesd schroot.conf
+
+ if use doc; then
+ docinto html/sbuild
+ dodoc "${BUILD_DIR}"/doc/sbuild/html/*
+ docinto html/schroot
+ dodoc "${BUILD_DIR}"/doc/schroot/html/*
+ fi
+
+ if use pam; then
+ rm -f "${ED}"/etc/pam.d/schroot
+ pamd_mimic_system schroot auth account session
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}