summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2016-05-05 23:53:14 +0200
committerIan Delaney <idella4@gentoo.org>2016-05-06 21:16:03 +0800
commita6f9a96fdec54406ab34904b13db89c0af9de89c (patch)
tree2a9af0426523cae28d93bd83e7b5e27aaca4513c /dev-util/serialtalk/serialtalk-9999.ebuild
parentdev-ml/batteries: make ocaml 4.03 patches conditional to having ocaml 4.03. (diff)
downloadgentoo-a6f9a96fdec54406ab34904b13db89c0af9de89c.tar.gz
gentoo-a6f9a96fdec54406ab34904b13db89c0af9de89c.tar.bz2
gentoo-a6f9a96fdec54406ab34904b13db89c0af9de89c.zip
dev-util/serialtalk: Initial commit.
This packages the released version 1.2 and adds a live-ebuild. Gentoo-Bug: https://bugs.gentoo.org/582182 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1416 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-util/serialtalk/serialtalk-9999.ebuild')
-rw-r--r--dev-util/serialtalk/serialtalk-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/serialtalk/serialtalk-9999.ebuild b/dev-util/serialtalk/serialtalk-9999.ebuild
new file mode 100644
index 000000000000..b083e3feb644
--- /dev/null
+++ b/dev-util/serialtalk/serialtalk-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/BGO-OD/serialtalk.git"
+else
+ SRC_URI="https://github.com/BGO-OD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple command-line tool to talk to serial devices"
+HOMEPAGE="https://github.com/BGO-OD/serialtalk"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_install() {
+ cmake-utils_src_install
+}