summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-07-29 01:21:52 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-07-29 01:28:40 -0700
commitde0eac8a38ac428c674f36fbaa873924e9297622 (patch)
treefa84162bf7e63946c7180a2ea7dcf1748fbddc9a /dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild
parentapp-vim/easytags: fix qa whitespace warning and update to EAPI 7 (diff)
downloadgentoo-de0eac8a38ac428c674f36fbaa873924e9297622.tar.gz
gentoo-de0eac8a38ac428c674f36fbaa873924e9297622.tar.bz2
gentoo-de0eac8a38ac428c674f36fbaa873924e9297622.zip
dev-util/shellcheck-bin: bump to 0.7.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild')
-rw-r--r--dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild b/dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild
new file mode 100644
index 000000000000..8b6f2c39aa76
--- /dev/null
+++ b/dev-util/shellcheck-bin/shellcheck-bin-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN/-bin/}
+
+DESCRIPTION="Shell script analysis tool (binary package)"
+HOMEPAGE="https://www.shellcheck.net/"
+SRC_URI="
+ amd64? ( https://storage.googleapis.com/${MY_PN}/${MY_PN}-v${PV}.linux.x86_64.tar.xz )
+ arm? ( https://storage.googleapis.com/${MY_PN}/${MY_PN}-v${PV}.linux.armv6hf.tar.xz )
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+DEPEND="!dev-util/shellcheck"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="/usr/bin/shellcheck"
+S="${WORKDIR}/${MY_PN}-v${PV}"
+
+src_install() {
+ dobin shellcheck
+ einstalldocs
+}