summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/skipfish/skipfish-2.10_beta.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/skipfish/skipfish-2.10_beta.ebuild')
-rw-r--r--dev-util/skipfish/skipfish-2.10_beta.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-util/skipfish/skipfish-2.10_beta.ebuild b/dev-util/skipfish/skipfish-2.10_beta.ebuild
new file mode 100644
index 000000000000..13a03f3cfc56
--- /dev/null
+++ b/dev-util/skipfish/skipfish-2.10_beta.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs versionator
+
+MY_P="$PN-$(get_version_component_range 1-2)b"
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/openssl:0
+ dev-libs/libpcre
+ net-dns/libidn
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ -e "/SIG_FILE/s:signatures/:/etc/skipfish/signatures/:" \
+ src/config.h || die
+
+ sed -i \
+ -e "s:signatures/:/etc/skipfish/signatures/:g" \
+ signatures/signatures.conf || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug}
+}
+
+src_install() {
+ dobin ${PN}
+ doman doc/${PN}.1
+
+ insinto /etc/skipfish
+ doins -r signatures
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl
+
+ dohtml assets/*
+
+ dodoc ChangeLog README doc/*.txt
+}