summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-22 15:48:04 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-22 22:58:34 -0400
commitef634a4e60380f157f05d6e8246fb249ea55cc19 (patch)
treefec3cb275d2eff4ecd7b44d495716752cc694d4b /dev-util/spirv-llvm-translator/spirv-llvm-translator-14.0.0-r1.ebuild
parentx11-apps/mesa-progs: defer to new global USE=vulkan description (diff)
downloadgentoo-ef634a4e60380f157f05d6e8246fb249ea55cc19.tar.gz
gentoo-ef634a4e60380f157f05d6e8246fb249ea55cc19.tar.bz2
gentoo-ef634a4e60380f157f05d6e8246fb249ea55cc19.zip
dev-util/spirv-llvm-translator: Look for spirv-headers in ESYSROOT
BROOT is for dependencies in BDEPEND, typically executable build tools. spirv-headers is in DEPEND/RDEPEND, and thus should be found in ESYSROOT. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/spirv-llvm-translator/spirv-llvm-translator-14.0.0-r1.ebuild')
-rw-r--r--dev-util/spirv-llvm-translator/spirv-llvm-translator-14.0.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/spirv-llvm-translator/spirv-llvm-translator-14.0.0-r1.ebuild b/dev-util/spirv-llvm-translator/spirv-llvm-translator-14.0.0-r1.ebuild
index 14c92492c2e6..022166bd2111 100644
--- a/dev-util/spirv-llvm-translator/spirv-llvm-translator-14.0.0-r1.ebuild
+++ b/dev-util/spirv-llvm-translator/spirv-llvm-translator-14.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -43,7 +43,7 @@ src_configure() {
local mycmakeargs=(
-DCCACHE_ALLOWED="OFF"
-DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix ${LLVM_MAX_SLOT})"
- -DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="${BROOT}/usr/include/spirv"
+ -DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR="${ESYSROOT}/usr/include/spirv"
-DLLVM_BUILD_TOOLS=$(usex tools "ON" "OFF")
-DLLVM_SPIRV_INCLUDE_TESTS=$(usex test "ON" "OFF")
-Wno-dev