summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:46:32 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:04 +0100
commit0f1b5a0b9fa66596ccbe41958ee79e3d8673ab44 (patch)
treefb29fddf6706e47ef12dc2bfec3dbe5d2f6c4845 /dev-util/statifier/statifier-1.7.4-r2.ebuild
parentdev-util/smem: drop 1.5-r1 (diff)
downloadgentoo-0f1b5a0b9fa66596ccbe41958ee79e3d8673ab44.tar.gz
gentoo-0f1b5a0b9fa66596ccbe41958ee79e3d8673ab44.tar.bz2
gentoo-0f1b5a0b9fa66596ccbe41958ee79e3d8673ab44.zip
dev-util/statifier: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/statifier/statifier-1.7.4-r2.ebuild')
-rw-r--r--dev-util/statifier/statifier-1.7.4-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/statifier/statifier-1.7.4-r2.ebuild b/dev-util/statifier/statifier-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..0c00e2573e74
--- /dev/null
+++ b/dev-util/statifier/statifier-1.7.4-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_{32,x32,64} )
+
+inherit flag-o-matic multilib-build toolchain-funcs
+
+DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
+HOMEPAGE="http://statifier.sourceforge.net"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="
+ app-shells/bash
+ sys-apps/coreutils
+ virtual/awk
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.4-clang.patch
+ "${FILESDIR}"/${PN}-1.7.4-fix-build-system.patch
+ "${FILESDIR}"/${PN}-1.7.4-musl.patch
+)
+
+src_prepare() {
+ default
+
+ # Don't compile 32-bit on amd64 no-multilib profile
+ if ! use abi_x86_32; then
+ sed -e 's/ELF32 .*/ELF32 := no/g' -i configs/config.x86_64 || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ # Debug flags are known to cause compile failure
+ filter-flags "-g*"
+
+ # Fix permissions, as configure is not marked executable
+ chmod +x configure || die
+ econf
+}
+
+src_compile() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1
+}
+
+src_install() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1 DESTDIR="${ED}" install
+
+ einstalldocs
+}