summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <ck+gentoo@bl4ckb0x.de>2018-03-23 00:43:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-23 09:24:39 +0100
commitefe2f748b658164a3b9ca0dd32ea2c70ee6048c2 (patch)
treeeadc681a22a612c7189600fc73d604b9e3961587 /dev-util/statifier/statifier-1.7.4.ebuild
parentdev-libs/librelp: stable 1.2.15 for sparc, bug #651192 (diff)
downloadgentoo-efe2f748b658164a3b9ca0dd32ea2c70ee6048c2.tar.gz
gentoo-efe2f748b658164a3b9ca0dd32ea2c70ee6048c2.tar.bz2
gentoo-efe2f748b658164a3b9ca0dd32ea2c70ee6048c2.zip
dev-util/statifier: added new ebuild
Closes: https://bugs.gentoo.org/649522 Closes: https://github.com/gentoo/gentoo/pull/7349
Diffstat (limited to 'dev-util/statifier/statifier-1.7.4.ebuild')
-rw-r--r--dev-util/statifier/statifier-1.7.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/statifier/statifier-1.7.4.ebuild b/dev-util/statifier/statifier-1.7.4.ebuild
new file mode 100644
index 000000000000..2e2867cd1b96
--- /dev/null
+++ b/dev-util/statifier/statifier-1.7.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
+HOMEPAGE="http://statifier.sourceforge.net"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="app-shells/bash
+ sys-apps/coreutils
+ virtual/awk"
+
+src_prepare() {
+ # Respect users CFLAGS and LDFLAGS
+ sed -i -e 's/-Wall -O2/$(CFLAGS) $(LDFLAGS)/g' src/Makefile || die
+
+ # Apply user patches
+ eapply_user
+}
+
+src_configure() {
+ # Fix permissions, as configure is not marked executable
+ chmod +x configure || die
+ econf
+}
+
+src_compile() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1
+}
+
+src_install() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1 DESTDIR="${D}" install
+
+ # Install docs
+ einstalldocs
+}