summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wrótniak <karol.wrotniak@droidsonroids.pl>2018-10-19 00:53:57 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-22 22:08:19 +0200
commitaeaea649e3402597ef9dd4305fb5fa59d102a3de (patch)
tree4208f697d08ccd9fe5bf1fdfbd5505ef4c132db5 /dev-util/stepman/stepman-0.10.4.ebuild
parentdev-util/envman: bump to 2.1.0 (diff)
downloadgentoo-aeaea649e3402597ef9dd4305fb5fa59d102a3de.tar.gz
gentoo-aeaea649e3402597ef9dd4305fb5fa59d102a3de.tar.bz2
gentoo-aeaea649e3402597ef9dd4305fb5fa59d102a3de.zip
dev-util/stepman: bump to 0.10.4
Signed-off-by: Karol Wrótniak <karol.wrotniak@droidsonroids.pl> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stepman/stepman-0.10.4.ebuild')
-rw-r--r--dev-util/stepman/stepman-0.10.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/stepman/stepman-0.10.4.ebuild b/dev-util/stepman/stepman-0.10.4.ebuild
new file mode 100644
index 000000000000..f95a6153f9c0
--- /dev/null
+++ b/dev-util/stepman/stepman-0.10.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Step collection manager for Bitrise CLI"
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ default
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/stepman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/stepman || die "Couldn't compile stepman"
+}
+
+src_test() {
+ pushd _tests/integration > /dev/null || die "Couldn't find integration tests directory"
+ rm update_test.go step_info_test.go setup_test.go || die "Couldn't remove network-dependent tests"
+ popd || die "Couldn't return to ${S} directory"
+ local -x INTEGRATION_TEST_BINARY_PATH="${S}/bin/stepman"
+ GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
+}
+
+src_install() {
+ dobin bin/stepman
+ dodoc README.md
+}