summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-08-14 09:55:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-08-14 09:55:28 +0200
commit2819ee5a31f7091797c5a47714dcfced18c9c4f5 (patch)
tree97738c84c75fc58ecbc27d722bc018e415c9dfd2 /dev-util/strace
parentnet-libs/libssh: Synced live ebuild. (diff)
downloadgentoo-2819ee5a31f7091797c5a47714dcfced18c9c4f5.tar.gz
gentoo-2819ee5a31f7091797c5a47714dcfced18c9c4f5.tar.bz2
gentoo-2819ee5a31f7091797c5a47714dcfced18c9c4f5.zip
dev-util/strace: Bump to version 4.24
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-4.24.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index 04bcc10a527c..638f51d6b64f 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -1,3 +1,4 @@
DIST strace-4.20.tar.xz 1132460 BLAKE2B 2e0e3080008ed1d5fd87572df740af8c62ebba44e0ece3c6b5ab581f246e79d8074a7fc2d0857abe158a055042fccbd880e11c9567beca1aeddc23f92d763c2d SHA512 869b3b9c48401619073a021e20e80cce37d8884f615bdb52dac9e6a2903df11507d7a0cb0ccad75bcc03d8dfafead0e68d14267e663503e94849079c9a2ebd4c
DIST strace-4.22.tar.xz 1232884 BLAKE2B 4053d1923ad1f942c3887be1716b400e426b318e136cc1cba1d83091445e2a3b64588c0578f0165ffec01dda1cb1824c29dbdab05bb409232edede953f2a5e78 SHA512 624c3f27921b6df2eb8ff409a35fa9153c4571cd5f703e6cac18f024bccd5ff4acb81f88ca33f81d1046d9718dec7b2705e8940e80bb8447ec3e62a6fd5f8350
DIST strace-4.23.tar.xz 1379128 BLAKE2B e1b680774172ba65190acc201a00f36ff608eb5a8239f8a6665b9f0eebfb7715eb3469d45c2333e4fac9a498ad3b448b1f39716b92cab91b035bc1e4125382eb SHA512 b54df972dc86e27668784ea4619e8c55230816b249e0a7fcca99a37b7f9ec37710742aca08c9e39b508522accb654a83c98207bab9ccac1197bb8e73e51ab116
+DIST strace-4.24.tar.xz 1398252 BLAKE2B ca83adfb3ccd23a55976c2950ce5911203e1ad911147649127e49d815e4899b5fd72459c371c15aea701d0d30e994d0eca2b32aad240fccc4e8d1cecb3f97558 SHA512 69cbf8b2c32c7ea90ebe5955bc71b454316a3494ae6975203fe61ce1f42ec539438cec5ba8ee7f529f89661d964b4aa53656712706aacff6bf018304b7a09813
diff --git a/dev-util/strace/strace-4.24.ebuild b/dev-util/strace/strace-4.24.ebuild
new file mode 100644
index 000000000000..a16ee1f785c0
--- /dev/null
+++ b/dev-util/strace/strace-4.24.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strace/strace.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="https://strace.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio perl static unwind elfutils"
+
+REQUIRED_USE="?? ( unwind elfutils )"
+
+LIB_DEPEND="
+ unwind? ( sys-libs/libunwind[static-libs(+)] )
+ elfutils? ( dev-libs/elfutils[static-libs(+)] )
+"
+# strace only uses the header from libaio to decode structs
+DEPEND="
+ static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+
+ if [[ ! -e configure ]] ; then
+ # git generation
+ ./xlat/gen.sh || die
+ ./generate_mpers_am.sh || die
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ # Add -pthread since strace wants -lrt for timer_create, and -lrt uses -lpthread.
+ use static && append-ldflags -static -pthread
+
+ export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
+
+ # Stub out the -k test since it's known to be flaky. #545812
+ sed -i '1iexit 77' tests*/strace-k.test || die
+}
+
+src_configure() {
+ # Set up the default build settings, and then use the names strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
+ # Don't require mpers support on non-multilib systems. #649560
+ econf \
+ --enable-mpers=check \
+ $(use_with unwind libunwind) \
+ $(use_with elfutils libdw)
+}
+
+src_test() {
+ if has usersandbox $FEATURES ; then
+ ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
+ return 0
+ fi
+
+ default
+}
+
+src_install() {
+ default
+ use perl || rm "${ED%/}"/usr/bin/strace-graph
+ dodoc CREDITS
+}