summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-08-10 14:29:47 -0700
committerMike Frysinger <vapier@gentoo.org>2018-08-14 18:13:40 -0400
commit09caf9c6b60784ab66b3ecdf65416f6d71e3fccb (patch)
treeaa2b0258a3fe0055776fc3ae72f742d4705f93c1 /dev-util/stressapptest/stressapptest-1.0.9.ebuild
parentsys-cluster/crmsh: version bump, fixes #612198 (diff)
downloadgentoo-09caf9c6b60784ab66b3ecdf65416f6d71e3fccb.tar.gz
gentoo-09caf9c6b60784ab66b3ecdf65416f6d71e3fccb.tar.bz2
gentoo-09caf9c6b60784ab66b3ecdf65416f6d71e3fccb.zip
dev-util/stressapptest: version bump to 1.0.9
Diffstat (limited to 'dev-util/stressapptest/stressapptest-1.0.9.ebuild')
-rw-r--r--dev-util/stressapptest/stressapptest-1.0.9.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/stressapptest/stressapptest-1.0.9.ebuild b/dev-util/stressapptest/stressapptest-1.0.9.ebuild
new file mode 100644
index 000000000000..27748ce9fde5
--- /dev/null
+++ b/dev-util/stressapptest/stressapptest-1.0.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic
+
+DESCRIPTION="Stressful Application Test"
+HOMEPAGE="https://github.com/stressapptest/stressapptest"
+SRC_URI="https://github.com/stressapptest/stressapptest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libaio"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Matches the configure & sat.cc logic.
+ use debug || append-cppflags -DNDEBUG -DCHECKOPTS
+ econf --disable-default-optimizations
+}