summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-23 01:41:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-23 01:46:33 +0100
commit8fc67b2ca46188da42ebf6fbd64c3d64ebdb7ef1 (patch)
tree0e6c0449619970b73c6273bb7dac4869f09d34d1 /dev-util/stripe-mock/stripe-mock-0.103.0.ebuild
parentdev-python/watchdog: Bump to 2.0.2 (diff)
downloadgentoo-8fc67b2ca46188da42ebf6fbd64c3d64ebdb7ef1.tar.gz
gentoo-8fc67b2ca46188da42ebf6fbd64c3d64ebdb7ef1.tar.bz2
gentoo-8fc67b2ca46188da42ebf6fbd64c3d64ebdb7ef1.zip
dev-util/stripe-mock: Bump to 0.103.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock/stripe-mock-0.103.0.ebuild')
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.103.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/stripe-mock-0.103.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.103.0.ebuild
new file mode 100644
index 000000000000..05a7220e34b0
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.103.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D}$(get_golibdir_gopath)" || die
+}