summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-29 06:06:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-29 06:06:10 +0200
commit0ee3f1101272d91a3951527c42e6c86a945e543f (patch)
treec3757380e0d46d613e6e432abdf2dd5626f92854 /dev-util/stripe-mock/stripe-mock-0.172.0.ebuild
parentdev-python/pyspnego: Bump to 0.9.2 (diff)
downloadgentoo-0ee3f1101272d91a3951527c42e6c86a945e543f.tar.gz
gentoo-0ee3f1101272d91a3951527c42e6c86a945e543f.tar.bz2
gentoo-0ee3f1101272d91a3951527c42e6c86a945e543f.zip
dev-util/stripe-mock: Bump to 0.172.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock/stripe-mock-0.172.0.ebuild')
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.172.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/stripe-mock-0.172.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.172.0.ebuild
new file mode 100644
index 000000000000..ca0f4e60efa7
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.172.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}