summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/suse-build/suse-build-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/suse-build/suse-build-9999.ebuild')
-rw-r--r--dev-util/suse-build/suse-build-9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/suse-build/suse-build-9999.ebuild b/dev-util/suse-build/suse-build-9999.ebuild
new file mode 100644
index 000000000000..3056206b4e11
--- /dev/null
+++ b/dev-util/suse-build/suse-build-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/openSUSE/obs-build.git"
+
+if [[ "${PV}" == "9999" ]]; then
+ EXTRA_ECLASS="git-2"
+else
+ OBS_PACKAGE="build"
+ OBS_PROJECT="openSUSE:Tools"
+ EXTRA_ECLASS="obs-download"
+fi
+
+inherit eutils ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Script to build SUSE Linux RPMs"
+HOMEPAGE="https://build.opensuse.org/package/show/openSUSE:Tools/build"
+
+[[ "${PV}" == "9999" ]] || SRC_URI="${OBS_URI}/${PN/suse/obs}-${PV//.}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="symlink"
+[[ "${PV}" == "9999" ]] || \
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ dev-perl/XML-Parser
+ dev-perl/TimeDate
+ app-shells/bash
+ app-arch/cpio
+ app-arch/rpm
+"
+
+S="${WORKDIR}/${PN/suse/obs}-${PV//.}"
+
+src_compile() { :; }
+
+src_install() {
+ emake DESTDIR="${ED}" pkglibdir=/usr/libexec/suse-build install
+ cd "${ED}"/usr
+ find bin -type l | while read i; do
+ mv "${i}" "${i/bin\//bin/suse-}"
+ use !symlink || dosym "${i/bin\//suse-}" "/usr/${i}"
+ done
+ find share/man/man1 -type f | while read i; do
+ mv "${i}" "${i/man1\//man1/suse-}"
+ use !symlink || dosym "${i/man1\//suse-}" "/usr/${i}"
+ done
+ find . -type f -exec sed -i 's|/usr/lib/build|/usr/libexec/suse-build|' {} +
+
+ # create symlink for default build config
+ dosym /usr/libexec/suse-build/configs/sl13.2.conf /usr/libexec/suse-build/configs/default.conf
+}