summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-08-07 13:35:12 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-08-08 15:18:11 +0300
commit47c07f65a4e3cbac2a6ddfcd5a709b363d7e2210 (patch)
treedc6e4be02f58a8a3d299a341605172dea64cb7a7 /dev-util/sysdig-kmod/sysdig-kmod-0.26.7-r1.ebuild
parentdev-util/lttng-modules: migrate to sys-apps/kmod (diff)
downloadgentoo-47c07f65a4e3cbac2a6ddfcd5a709b363d7e2210.tar.gz
gentoo-47c07f65a4e3cbac2a6ddfcd5a709b363d7e2210.tar.bz2
gentoo-47c07f65a4e3cbac2a6ddfcd5a709b363d7e2210.zip
dev-util/sysdig-kmod: migrate to sys-apps/kmod
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-util/sysdig-kmod/sysdig-kmod-0.26.7-r1.ebuild')
-rw-r--r--dev-util/sysdig-kmod/sysdig-kmod-0.26.7-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/sysdig-kmod/sysdig-kmod-0.26.7-r1.ebuild b/dev-util/sysdig-kmod/sysdig-kmod-0.26.7-r1.ebuild
new file mode 100644
index 000000000000..ba7201399d5c
--- /dev/null
+++ b/dev-util/sysdig-kmod/sysdig-kmod-0.26.7-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake linux-mod
+
+MY_P=${P/-kmod}
+DESCRIPTION="Kernel module for dev-util/sysdig"
+HOMEPAGE="https://sysdig.com/"
+SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( MIT GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!<=dev-util/sysdig-0.26.4[modules]"
+
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
+
+pkg_pretend() {
+ linux-mod_pkg_setup
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e '/USE_BUNDLED_DEPS/,$d' CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # we will use linux-mod for that
+ -DBUILD_DRIVER=OFF
+ )
+
+ cmake_src_configure
+
+ # setup linux-mod ugliness
+ MODULE_NAMES="sysdig-probe(extra:${BUILD_DIR}/driver/src:)"
+ BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
+ BUILD_TARGETS="all"
+}