summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-03 19:59:10 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-03 20:31:02 -0500
commit7c1c769f789d5afe44d2f07c954c3e72681eefc5 (patch)
tree2831a64c6167042f442b4efdbeb5528343ec77f7 /dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild
parentdev-util/sysprof-common: Add package (diff)
downloadgentoo-7c1c769f789d5afe44d2f07c954c3e72681eefc5.tar.gz
gentoo-7c1c769f789d5afe44d2f07c954c3e72681eefc5.tar.bz2
gentoo-7c1c769f789d5afe44d2f07c954c3e72681eefc5.zip
dev-util/sysprof-capture: Don't install org.gnome.Sysprof3.Profiler.xml
Will now be provided by dev-util/sysprof-common. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild')
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild
new file mode 100644
index 000000000000..f5767d87f270
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="3"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.61.3:2
+ !=dev-util/sysprof-3.34.1-r0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dlibunwind=false
+ )
+ meson_src_configure
+}