summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-19 11:49:48 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-19 11:59:08 -0500
commit1352148f04679ec665f6342533a5a049757af0e0 (patch)
tree635b797b361c732c58dd5b62506d2b79353ffcee /dev-util/sysprof-capture
parentdev-util/sysprof-common: Version bump to 3.42.1 (diff)
downloadgentoo-1352148f04679ec665f6342533a5a049757af0e0.tar.gz
gentoo-1352148f04679ec665f6342533a5a049757af0e0.tar.bz2
gentoo-1352148f04679ec665f6342533a5a049757af0e0.zip
dev-util/sysprof-capture: Version bump to 3.42.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/sysprof-capture')
-rw-r--r--dev-util/sysprof-capture/Manifest1
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.42.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
index 42a4802cbe1c..9280314ff315 100644
--- a/dev-util/sysprof-capture/Manifest
+++ b/dev-util/sysprof-capture/Manifest
@@ -1,3 +1,4 @@
DIST sysprof-3.36.0.tar.xz 435956 BLAKE2B 990a6c6c28339594df915ed1fb98f504bf6b080a5e3c31af0cc4bcfd208027361f02a9068291692d082787a6fd42ab414079122a63e4706aee2511040379f0c8 SHA512 41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4
DIST sysprof-3.38.1.tar.xz 458572 BLAKE2B 68c219a6c80ed070314fc7718a2995c49821cc7c761b277fdd29c233da9d81b561b6c68cd0d0a42cc3e4c150e3de438322f7d418140ce19f3381f4ffac78aa1a SHA512 7ba3dd51bd4055dcdf4d46ff87e46537afe42ba009809fdee5ba0ebcdf70776d9e1ff812714096d33b09ac57d459707b92b1ca07682e2f3888b612ca74820442
DIST sysprof-3.40.1.tar.xz 468320 BLAKE2B fcba3b627ea32c38e621046027fced7478b6c57ba5487834d35fdde45a38bf4df66e5d696e93627217fa237978a6e7074b9e92ae89f963db7b6fca4482b59053 SHA512 ad07fd21066dfa6c7be81acdb720d97f392e1bbd05e71dd45d743b10a631b2b2c4c1177086f28e7f500271add79aa3356dd2aebdb97604357c4fef43809ead87
+DIST sysprof-3.42.1.tar.xz 484096 BLAKE2B bc1124651f6323d6757050ef3225df222039ac7a5c6a6e2a0e170354a0e89705ea03173302ac7fa2bc172b27485d4e4cdee0f7504a548d51e88b88a19cc8cc9d SHA512 15bf7efadfc88c1342200009e4b74ecd23a320ca272b4ca3736dd41baf9cb4e0a1fd75e0aa20ee784b98c6fee7f86a2b52e63bc4769b6ca9759f58b64cba0dcd
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.42.1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.42.1.ebuild
new file mode 100644
index 000000000000..5776dd55674d
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.42.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson-multilib systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!=dev-util/sysprof-3.34.1-r0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dlibunwind=false
+ -Denable_tools=false
+ -Denable_tests=false
+ -Denable_examples=false
+ )
+ meson_src_configure
+}