summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-25 11:12:03 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-25 11:23:21 -0700
commit8178658d62e22111039965f0b9bfe22843dcfdc8 (patch)
tree711cdc76637b8d9bc89a38389ff042d2e16acfbc /dev-util/sysprof-capture
parentdev-util/sysprof-common: Version bump to 3.44.0 (diff)
downloadgentoo-8178658d62e22111039965f0b9bfe22843dcfdc8.tar.gz
gentoo-8178658d62e22111039965f0b9bfe22843dcfdc8.tar.bz2
gentoo-8178658d62e22111039965f0b9bfe22843dcfdc8.zip
dev-util/sysprof-capture: Version bump to 3.44.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/sysprof-capture')
-rw-r--r--dev-util/sysprof-capture/Manifest1
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.44.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
index fe425b4028c5..6aee2c9239f8 100644
--- a/dev-util/sysprof-capture/Manifest
+++ b/dev-util/sysprof-capture/Manifest
@@ -1,2 +1,3 @@
DIST sysprof-3.36.0.tar.xz 435956 BLAKE2B 990a6c6c28339594df915ed1fb98f504bf6b080a5e3c31af0cc4bcfd208027361f02a9068291692d082787a6fd42ab414079122a63e4706aee2511040379f0c8 SHA512 41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4
DIST sysprof-3.42.1.tar.xz 484096 BLAKE2B bc1124651f6323d6757050ef3225df222039ac7a5c6a6e2a0e170354a0e89705ea03173302ac7fa2bc172b27485d4e4cdee0f7504a548d51e88b88a19cc8cc9d SHA512 15bf7efadfc88c1342200009e4b74ecd23a320ca272b4ca3736dd41baf9cb4e0a1fd75e0aa20ee784b98c6fee7f86a2b52e63bc4769b6ca9759f58b64cba0dcd
+DIST sysprof-3.44.0.tar.xz 493924 BLAKE2B c3d9558df99ba23f63fbde0df54e201afce83da8f7d64166b44fcc2c70ec9e54a4abfbd0ac64171b1538af7e9d608b0f618559aba9444a3d884cd4944c4d595f SHA512 64bfe4d39e71954f7982ef06caffc39ff60d2d6005f8392a7918f83263d7c5b11bafdf7234ed86d52063586919a4dbe742c498b6f1f9db91d481337cf568451c
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.44.0.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.44.0.ebuild
new file mode 100644
index 000000000000..0685cabc9dbd
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.44.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson-multilib systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!=dev-util/sysprof-3.34.1-r0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dlibunwind=false
+ -Denable_tools=false
+ -Denable_tests=false
+ -Denable_examples=false
+ )
+ meson_src_configure
+}