summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-11 13:29:49 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-11 13:31:06 -0700
commite23c78ce6df9352f301335fe397543d3ea5f9e0b (patch)
tree0f0006efbc9cbff72b49e01f41020b4514d287ef /dev-util/trace-cmd
parentprofiles: arm64: Streamline comments, add bug ref (diff)
downloadgentoo-e23c78ce6df9352f301335fe397543d3ea5f9e0b.tar.gz
gentoo-e23c78ce6df9352f301335fe397543d3ea5f9e0b.tar.bz2
gentoo-e23c78ce6df9352f301335fe397543d3ea5f9e0b.zip
dev-util/trace-cmd: Revbump to 2.7-r1, fix dynlib and plugin inst
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/trace-cmd')
-rw-r--r--dev-util/trace-cmd/files/trace-cmd-2.7-soname.patch13
-rw-r--r--dev-util/trace-cmd/trace-cmd-2.7-r1.ebuild (renamed from dev-util/trace-cmd/trace-cmd-2.7.ebuild)20
-rw-r--r--dev-util/trace-cmd/trace-cmd-9999.ebuild18
3 files changed, 38 insertions, 13 deletions
diff --git a/dev-util/trace-cmd/files/trace-cmd-2.7-soname.patch b/dev-util/trace-cmd/files/trace-cmd-2.7-soname.patch
new file mode 100644
index 000000000000..937f0617a4a4
--- /dev/null
+++ b/dev-util/trace-cmd/files/trace-cmd-2.7-soname.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index a5d2c38..588809e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -308,7 +308,7 @@ do_app_build = \
+
+ do_compile_shared_library = \
+ ($(print_shared_lib_compile) \
+- $(CC) --shared $^ -o $@)
++ $(CC) --shared $^ -Wl,-soname,$@ -o $@)
+
+ do_compile_plugin_obj = \
+ ($(print_plugin_obj_compile) \
diff --git a/dev-util/trace-cmd/trace-cmd-2.7.ebuild b/dev-util/trace-cmd/trace-cmd-2.7-r1.ebuild
index edebefd435ba..6fd69e83c236 100644
--- a/dev-util/trace-cmd/trace-cmd-2.7.ebuild
+++ b/dev-util/trace-cmd/trace-cmd-2.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,17 +13,18 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/${PN}.git"
inherit git-r3
else
- SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git/snapshot/${PN}-v${PV}.tar.gz"
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/${PN}.git/snapshot/${PN}-v${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-v${PV}"
fi
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
-IUSE="doc gtk python udis86"
+IUSE="+audit doc gtk python udis86"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )
+RDEPEND="audit? ( sys-process/audit )
+ python? ( ${PYTHON_DEPS} )
udis86? ( dev-libs/udis86 )
gtk? (
${PYTHON_DEPS}
@@ -45,6 +46,7 @@ CONFIG_CHECK="
PATCHES=(
"${FILESDIR}"/${PN}-2.7-makefile.patch
+ "${FILESDIR}"/${PN}-2.7-soname.patch
)
pkg_setup() {
@@ -53,7 +55,11 @@ pkg_setup() {
}
src_configure() {
- MAKEOPTS+=" prefix=/usr libdir=$(get_libdir) CC=$(tc-getCC) AR=$(tc-getAR)"
+ MAKEOPTS+=" prefix=/usr
+ libdir=/usr/$(get_libdir)
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ $(usex audit '' '' 'NO_AUDIT=1')"
if use python; then
MAKEOPTS+=" PYTHON_VERS=${EPYTHON//python/python-}"
@@ -66,13 +72,13 @@ src_configure() {
}
src_compile() {
- emake all_cmd
+ emake V=1 all_cmd libs
use doc && emake doc
use gtk && emake -j1 gui
}
src_install() {
- default
+ emake DESTDIR="${D}" V=1 install install_libs
use doc && emake DESTDIR="${D}" install_doc
use gtk && emake DESTDIR="${D}" install_gui
}
diff --git a/dev-util/trace-cmd/trace-cmd-9999.ebuild b/dev-util/trace-cmd/trace-cmd-9999.ebuild
index edebefd435ba..f6463fe7257f 100644
--- a/dev-util/trace-cmd/trace-cmd-9999.ebuild
+++ b/dev-util/trace-cmd/trace-cmd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,10 +20,11 @@ fi
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
-IUSE="doc gtk python udis86"
+IUSE="+audit doc gtk python udis86"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )
+RDEPEND="audit? ( sys-process/audit )
+ python? ( ${PYTHON_DEPS} )
udis86? ( dev-libs/udis86 )
gtk? (
${PYTHON_DEPS}
@@ -45,6 +46,7 @@ CONFIG_CHECK="
PATCHES=(
"${FILESDIR}"/${PN}-2.7-makefile.patch
+ "${FILESDIR}"/${PN}-2.7-soname.patch
)
pkg_setup() {
@@ -53,7 +55,11 @@ pkg_setup() {
}
src_configure() {
- MAKEOPTS+=" prefix=/usr libdir=$(get_libdir) CC=$(tc-getCC) AR=$(tc-getAR)"
+ MAKEOPTS+=" prefix=/usr
+ libdir=/usr/$(get_libdir)
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ $(usex audit '' '' 'NO_AUDIT=1')"
if use python; then
MAKEOPTS+=" PYTHON_VERS=${EPYTHON//python/python-}"
@@ -66,13 +72,13 @@ src_configure() {
}
src_compile() {
- emake all_cmd
+ emake V=1 all_cmd libs
use doc && emake doc
use gtk && emake -j1 gui
}
src_install() {
- default
+ emake DESTDIR="${D}" V=1 install install_libs
use doc && emake DESTDIR="${D}" install_doc
use gtk && emake DESTDIR="${D}" install_gui
}