summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2021-10-10 16:05:40 +0200
committerGuilherme Amadio <amadio@gentoo.org>2021-10-10 16:05:40 +0200
commit8bcf692473430521869bd5f9ad58598feb083ebe (patch)
tree499fef5eeb71ea560c8b61682bb13eebaf8587c5 /dev-util/uftrace
parentdev-perl/Chatbot-Eliza: EAPI=8 bump (diff)
downloadgentoo-8bcf692473430521869bd5f9ad58598feb083ebe.tar.gz
gentoo-8bcf692473430521869bd5f9ad58598feb083ebe.tar.bz2
gentoo-8bcf692473430521869bd5f9ad58598feb083ebe.zip
dev-util/uftrace: version bump to 0.11
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-util/uftrace')
-rw-r--r--dev-util/uftrace/Manifest1
-rw-r--r--dev-util/uftrace/uftrace-0.11.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/uftrace/Manifest b/dev-util/uftrace/Manifest
index 8348aba2e207..174cc6499375 100644
--- a/dev-util/uftrace/Manifest
+++ b/dev-util/uftrace/Manifest
@@ -1 +1,2 @@
DIST uftrace-0.10.tar.gz 1111530 BLAKE2B 29388523e1009276ba4609d85e5979e823d028ff647239aa02ec2cac5ae21c7812c7699d47c09c0b9289a0debb39a2f502615547c8e658a821d5078e3b12c6fe SHA512 788234e4156974a70f06d02527e56e5fac821e8b66363dc5fc55d68797c374043c0b66b18b4ab1488b9647e08969e8dc94a64d6bb1a38ccad4cf98eaecc6e919
+DIST uftrace-0.11.tar.gz 1120956 BLAKE2B e3bda84a7323cc50780950e502856e28a380249a0f518ad3f7950c4147f0ab635e84b978395eb9025e6b47ecf7eefddcde59356a22f1c8a1d60ddf9820dc3d41 SHA512 519ca13665ba97cea4c349d81b4b5cacd8d3d9b2188ef5edb447f6b783cb7a92356bc0f9e63b67427a896d8df671f58091113e1de3fffd8d8000417a9fdb6e46
diff --git a/dev-util/uftrace/uftrace-0.11.ebuild b/dev-util/uftrace/uftrace-0.11.ebuild
new file mode 100644
index 000000000000..31a949ddbd3f
--- /dev/null
+++ b/dev-util/uftrace/uftrace-0.11.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( luajit )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 lua-single python-single-r1 toolchain-funcs
+
+DESCRIPTION="Function (graph) tracer for user-space"
+HOMEPAGE="https://github.com/namhyung/uftrace"
+SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="capstone lua python unwind"
+
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RESTRICT="test"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ virtual/libelf:=
+ capstone? ( dev-libs/capstone:0= )
+ lua? ( ${LUA_DEPS} )
+ python? ( ${PYTHON_DEPS} )
+ unwind? ( sys-libs/libunwind:= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
+}
+
+src_configure() {
+ local myconf=(
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/uftrace
+ $(use_with capstone)
+ $(use_with unwind libunwind)
+ $(use_with python libpython)
+ )
+ if use lua && use lua_single_target_luajit; then
+ myconf+=(
+ --with-libluajit
+ )
+ else
+ myconf+=(
+ --without-libluajit
+ )
+ fi
+ CC=$(tc-getCC) LD=$(tc-getLD) econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ dodoc doc/*.{md,gif,png}
+ newbashcomp misc/bash-completion.sh uftrace
+}