summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 00:37:27 +0000
committerSam James <sam@gentoo.org>2022-03-20 00:37:27 +0000
commitbc81afd289372e76f825911647ca3ce5ccfffd9b (patch)
treec631b2783db16cb2d5ba301ec282bc0d1f3e3f86 /dev-util/uftrace
parentdev-util/lockrun: [QA] fix tc-get* quoting (diff)
downloadgentoo-bc81afd289372e76f825911647ca3ce5ccfffd9b.tar.gz
gentoo-bc81afd289372e76f825911647ca3ce5ccfffd9b.tar.bz2
gentoo-bc81afd289372e76f825911647ca3ce5ccfffd9b.zip
dev-util/uftrace: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/uftrace')
-rw-r--r--dev-util/uftrace/uftrace-0.10-r1.ebuild6
-rw-r--r--dev-util/uftrace/uftrace-0.11.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-util/uftrace/uftrace-0.10-r1.ebuild b/dev-util/uftrace/uftrace-0.10-r1.ebuild
index 2b39cc144648..e29becbcca74 100644
--- a/dev-util/uftrace/uftrace-0.10-r1.ebuild
+++ b/dev-util/uftrace/uftrace-0.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,7 +35,7 @@ src_prepare() {
src_configure() {
local myconf=(
- --libdir="${EPREFIX}"/usr/$(get_libdir)/uftrace
+ --libdir="${EPREFIX}/usr/$(get_libdir)/uftrace"
$(use_with capstone)
--without-libpython
)
@@ -48,7 +48,7 @@ src_configure() {
--without-libluajit
)
fi
- CC=$(tc-getCC) LD=$(tc-getLD) econf "${myconf[@]}"
+ CC="$(tc-getCC)" LD="$(tc-getLD)" econf "${myconf[@]}"
}
src_compile() {
diff --git a/dev-util/uftrace/uftrace-0.11.ebuild b/dev-util/uftrace/uftrace-0.11.ebuild
index 31a949ddbd3f..932d17460e98 100644
--- a/dev-util/uftrace/uftrace-0.11.ebuild
+++ b/dev-util/uftrace/uftrace-0.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,7 +41,7 @@ src_prepare() {
src_configure() {
local myconf=(
- --libdir="${EPREFIX}"/usr/$(get_libdir)/uftrace
+ --libdir="${EPREFIX}/usr/$(get_libdir)/uftrace"
$(use_with capstone)
$(use_with unwind libunwind)
$(use_with python libpython)
@@ -55,7 +55,7 @@ src_configure() {
--without-libluajit
)
fi
- CC=$(tc-getCC) LD=$(tc-getLD) econf "${myconf[@]}"
+ CC="$(tc-getCC)" LD="$(tc-getLD)" econf "${myconf[@]}"
}
src_compile() {