summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-07-10 21:04:21 -0400
committerNick Sarnie <sarnex@gentoo.org>2018-07-10 21:05:44 -0400
commit7ae7e27e486d46bc97fe496af06031f99bcaaaf3 (patch)
treead79cf56485f1f21240e57e5be120c174ee4bcf3 /dev-util/vulkan-tools
parentdev-util/vulkan-tools: Rename cube and cubepp demos (diff)
downloadgentoo-7ae7e27e486d46bc97fe496af06031f99bcaaaf3.tar.gz
gentoo-7ae7e27e486d46bc97fe496af06031f99bcaaaf3.tar.bz2
gentoo-7ae7e27e486d46bc97fe496af06031f99bcaaaf3.zip
dev-util/vulkan-tools: Drop old
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-util/vulkan-tools')
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-1.1.77.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-util/vulkan-tools/vulkan-tools-1.1.77.0.ebuild b/dev-util/vulkan-tools/vulkan-tools-1.1.77.0.ebuild
deleted file mode 100644
index 3ffd734f550b..000000000000
--- a/dev-util/vulkan-tools/vulkan-tools-1.1.77.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Tools.git"
- EGIT_SUBMODULES=()
- inherit git-r3
-else
- EGIT_COMMIT="384fff68c802a10b5d7f4f352a4bb43b3efe5f23"
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-Tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-Tools-${EGIT_COMMIT}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="X wayland"
-
-# Old packaging will cause file collisions
-RDEPEND="!<=media-libs/vulkan-loader-1.1.70.0-r999"
-DEPEND="${PYTHON_DEPS}
- dev-util/glslang:=[${MULTILIB_USEDEP}]
- dev-util/vulkan-headers
- media-libs/vulkan-loader:=[${MULTILIB_USEDEP},wayland?,X?]
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? (
- x11-libs/libX11:=[${MULTILIB_USEDEP}]
- x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
- )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- -DGLSLANG_INSTALL_DIR="/usr"
- -DVULKAN_HEADERS_INSTALL_DIR="/usr"
- )
- cmake-utils_src_configure
-}