summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-21 21:59:04 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-21 21:59:04 +0200
commit02b3815496faac251b70fd26aed7ac8a400531b8 (patch)
tree7887b072f9c3dc0ebc8d969833b6c27409fce021 /dev-util/xdelta/xdelta-1.1.4-r3.ebuild
parentdev-lang/julia: Revbump with system-llvm useflag, unkeyworded (diff)
downloadgentoo-02b3815496faac251b70fd26aed7ac8a400531b8.tar.gz
gentoo-02b3815496faac251b70fd26aed7ac8a400531b8.tar.bz2
gentoo-02b3815496faac251b70fd26aed7ac8a400531b8.zip
dev-util/xdelta: [QA] Do not install static archives
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/xdelta/xdelta-1.1.4-r3.ebuild')
-rw-r--r--dev-util/xdelta/xdelta-1.1.4-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/xdelta/xdelta-1.1.4-r3.ebuild b/dev-util/xdelta/xdelta-1.1.4-r3.ebuild
new file mode 100644
index 000000000000..13f4fe56b9fc
--- /dev/null
+++ b/dev-util/xdelta/xdelta-1.1.4-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Computes changes between binary or text files and creates deltas"
+HOMEPAGE="https://xdelta.googlecode.com/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
+
+RDEPEND=">=dev-libs/glib-2
+ >=sys-libs/zlib-1.1.4:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+ eapply "${FILESDIR}"/${P}-m4.patch
+ eapply "${FILESDIR}"/${P}-glib2.patch
+ eapply "${FILESDIR}"/${P}-pkgconfig.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}