summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/xesam-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/xesam-tools')
-rw-r--r--dev-util/xesam-tools/Manifest1
-rw-r--r--dev-util/xesam-tools/metadata.xml12
-rw-r--r--dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild43
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/xesam-tools/Manifest b/dev-util/xesam-tools/Manifest
new file mode 100644
index 000000000000..c7d1358a05a1
--- /dev/null
+++ b/dev-util/xesam-tools/Manifest
@@ -0,0 +1 @@
+DIST xesam-tools-0.7.0.tar.gz 73173 SHA256 b73264bd392e3031c54cc112bd6d6780d78d9d20150954653415a25c9ab6ff96 SHA512 3428e18eb52fa205bca872c8b0b1f12f01f58a8fb43239bc2cc78fe52f9903940702dae4116d4775340b69ec949ad2198b57c0c1246fe58dd8ed8b7a6562bf71 WHIRLPOOL d2645d395ceafdcaf852ed287d5c472d5d666e461d1f35ebb289ee91f60aaae50e2b468d37ec5e815a2abd0a25c5b250be42f2da2bb213d15f7b29dfecd72868
diff --git a/dev-util/xesam-tools/metadata.xml b/dev-util/xesam-tools/metadata.xml
new file mode 100644
index 000000000000..5db1e619e0b5
--- /dev/null
+++ b/dev-util/xesam-tools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ xesam-tools provides a set of tools and examples to help developers
+ who are working on servers or clients which implement the Xesam desktop
+ search specification
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild b/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..81e959e49d03
--- /dev/null
+++ b/dev-util/xesam-tools/xesam-tools-0.7.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools and examples for the Xesam desktop search API"
+HOMEPAGE="http://xesam.org/people/kamstrup/xesam-tools"
+SRC_URI="http://xesam.org/people/kamstrup/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto "/usr/share/doc/${PF}"
+ doins -r samples
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/demo"
+ doins "demo/demo.py"
+ insopts -m 0755
+ doins demo/[^d]*
+ fi
+}