summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-07-12 23:19:57 +0100
committerMarek Szuba <marecki@gentoo.org>2022-07-12 23:20:18 +0100
commitf39d0ce89ece5a3f09babd0b9419b6b60a42178a (patch)
treeecbb0f1a41387d82bb3598b25f8aba6f756cfc23 /dev-util/yamllint
parentapp-containers/apptainer: add 1.0.3 (diff)
downloadgentoo-f39d0ce89ece5a3f09babd0b9419b6b60a42178a.tar.gz
gentoo-f39d0ce89ece5a3f09babd0b9419b6b60a42178a.tar.bz2
gentoo-f39d0ce89ece5a3f09babd0b9419b6b60a42178a.zip
dev-util/yamllint: add 1.27.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util/yamllint')
-rw-r--r--dev-util/yamllint/Manifest1
-rw-r--r--dev-util/yamllint/yamllint-1.27.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/yamllint/Manifest b/dev-util/yamllint/Manifest
index 0ac8de71b8cf..e1d3d267974f 100644
--- a/dev-util/yamllint/Manifest
+++ b/dev-util/yamllint/Manifest
@@ -1 +1,2 @@
DIST yamllint-1.26.3.tar.gz 126746 BLAKE2B 37d4293a90b2ee7192e26c5dbb1448a2c22a47e8dae7113211bb5601f0ef0c01eabd85fe4df44b32b8226b2b805c1da11ef1e118f5e33a2a7bab137141f9853c SHA512 c5ed17ecec102324bec077484dcede6fbf8c01a37a9292929a52163a4a9d9e9989809879c29b69c45b7cce8cbeefc830d4542118f617e846702f216f49d9db5b
+DIST yamllint-1.27.1.tar.gz 129052 BLAKE2B 37021bd577384821b75ddd747f1dd3c4261317582d42179e0731214cb67f79bf9302c34acaa721440edb118ef8900cc2952d1f8e441def9e3143b57e03af87bd SHA512 c00fcb5da35f79b0f877f1b8c3e5f1ff8c5d161dd795d3a2657e44e27d8b943961984bf15c294be263e00bf9dfcaf3dbf16ef8fd7354bedc8ed92e3e24ce4baf
diff --git a/dev-util/yamllint/yamllint-1.27.1.ebuild b/dev-util/yamllint/yamllint-1.27.1.ebuild
new file mode 100644
index 000000000000..7ebbb2e782d0
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.27.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest