summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Strahl <c.a.strahl@gmail.com>2018-09-22 13:12:35 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-23 10:41:06 -0700
commit0d3567bf9e5792eaec43f558899044da757d2d3a (patch)
tree38aa49487b0d89e307c95ae2a21f8555cbed40b3 /dev-util
parentsys-auth/pambase: Drop old (diff)
downloadgentoo-0d3567bf9e5792eaec43f558899044da757d2d3a.tar.gz
gentoo-0d3567bf9e5792eaec43f558899044da757d2d3a.tar.bz2
gentoo-0d3567bf9e5792eaec43f558899044da757d2d3a.zip
dev-util/clion: version bump to 2018.2.4
Package-Manager: Portage-2.3.40-r1, Repoman-2.3.9 Signed-off-by: Christian Strahl <c.a.strahl@gmail.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9944
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/clion/Manifest1
-rw-r--r--dev-util/clion/clion-2018.2.4.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index 0e0998dd0b90..733d2febd16d 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1 +1,2 @@
+DIST clion-2018.2.4.tar.gz 462328661 BLAKE2B 18975d4cad41237377c4df1064adb9c31a0c24d305dd1fca82c1fe492d81705818d28d9fe001d660a468a66642b820c77cd4c087e677bfbb96418bbbd2dccdd9 SHA512 d8b6c7d0e07db64065ccce4937d8ccc9eb0d8c6462bf29446cd32349c8c19721e31e6b87adab4850cc9f52763ae7bc93f287c63fae72f1ffe237994906160c57
DIST clion-2018.2.tar.gz 456219123 BLAKE2B 1cb719596568b7208658f01c9495b2948490c2f27f9d3eec6bb652d65e60374232b286b6fc889510c88855cfdd890c516e268c783b1d3ae5e54c42fbd68c047e SHA512 ce21c94e89c7966784a4ebe07c2324cf674187e67eb9362af9bcd6a299b1ef69f45c8b95f91db244db4a2a70e72d849a752741b2c9730477df35f09ab13ab807
diff --git a/dev-util/clion/clion-2018.2.4.ebuild b/dev-util/clion/clion-2018.2.4.ebuild
new file mode 100644
index 000000000000..d000021e40fe
--- /dev/null
+++ b/dev-util/clion/clion-2018.2.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eutils
+
+DESCRIPTION="A complete toolset for C and C++ development"
+HOMEPAGE="http://www.jetbrains.com/clion"
+SRC_URI="http://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="splitdebug"
+IUSE="-custom-jdk"
+
+# RDEPENDS may cause false positives in repoman.
+# clion requires cmake and gdb at runtime to build and debug C/C++ projects
+RDEPEND="
+ sys-devel/gdb
+ dev-util/cmake
+ !custom-jdk? ( virtual/jdk )"
+
+QA_PREBUILT="opt/${P}/*"
+
+src_prepare() {
+ default
+
+ local remove_me=(
+ bin/gdb/linux
+ bin/lldb/linux
+ bin/cmake
+ license/CMake*
+ plugins/tfsIntegration/lib/native/hpux
+ plugins/tfsIntegration/lib/native/solaris
+ )
+
+ use amd64 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86_64 )
+ use arm || remove_me+=( bin/fsnotifier-arm plugins/tfsIntegration/lib/native/linux/arm )
+ use ppc || remove_me+=( plugins/tfsIntegration/lib/native/linux/ppc )
+ use x86 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86 )
+
+ use custom-jdk || remove_me+=( jre64 )
+
+ rm -rv "${remove_me[@]}" || die
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{clion.sh,fsnotifier{,64},clang/linux/clang{d,-tidy}}
+
+ if use custom-jdk; then
+ if [[ -d jre64 ]]; then
+ fperms 755 "${dir}"/jre64/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
+ fi
+ fi
+
+ make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+ newicon "bin/${PN}.svg" "${PN}.svg"
+ make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ dodir /usr/lib/sysctl.d/
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
+}