summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-26 07:10:36 +0000
committerSam James <sam@gentoo.org>2023-01-26 07:14:50 +0000
commit1081e019e0dd2d41ad2d9832e7a7e0209865cbca (patch)
tree65021d29abf98065813f1f1dd6732c72a1668f6b /dev-util
parentdev-perl/IO-Socket-SSL: add 2.81.0 (diff)
downloadgentoo-1081e019e0dd2d41ad2d9832e7a7e0209865cbca.tar.gz
gentoo-1081e019e0dd2d41ad2d9832e7a7e0209865cbca.tar.bz2
gentoo-1081e019e0dd2d41ad2d9832e7a7e0209865cbca.zip
dev-util/heaptrack: fix build w/ gcc 13
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/heaptrack/files/heaptrack-1.4.0-gcc-13.patch22
-rw-r--r--dev-util/heaptrack/heaptrack-1.4.0.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-util/heaptrack/files/heaptrack-1.4.0-gcc-13.patch b/dev-util/heaptrack/files/heaptrack-1.4.0-gcc-13.patch
new file mode 100644
index 000000000000..706d479f5275
--- /dev/null
+++ b/dev-util/heaptrack/files/heaptrack-1.4.0-gcc-13.patch
@@ -0,0 +1,22 @@
+https://invent.kde.org/sdk/heaptrack/-/commit/315aa7116d588f92b67c4bb84e1549529cb2fca0
+
+From 315aa7116d588f92b67c4bb84e1549529cb2fca0 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Mon, 23 Jan 2023 23:44:09 +0100
+Subject: [PATCH] Fix build with gcc 13 by including <cstdint>
+
+Like other versions before, gcc 13 moved some includes around and as a
+result <cstdint> is no longer transitively included [1]. Explicitly include
+it for uint{32,64}_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+--- a/src/util/linereader.h
++++ b/src/util/linereader.h
+@@ -7,6 +7,7 @@
+ #ifndef LINEREADER_H
+ #define LINEREADER_H
+
++#include <cstdint>
+ #include <istream>
+ #include <string>
+
diff --git a/dev-util/heaptrack/heaptrack-1.4.0.ebuild b/dev-util/heaptrack/heaptrack-1.4.0.ebuild
index 29eec26eb107..01e625807144 100644
--- a/dev-util/heaptrack/heaptrack-1.4.0.ebuild
+++ b/dev-util/heaptrack/heaptrack-1.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -46,6 +46,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-boost-1.81.patch # bug #887033, in master
+ "${FILESDIR}"/${P}-gcc-13.patch # in master
)
src_prepare() {