summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-28 18:42:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-28 19:09:01 +0200
commit145fbf100e4f0e9d75f24b08f403dcc43137d2f8 (patch)
tree6c2c1dceb72727956cb0b0a4516a442f400fecd8 /dev-util
parentdev-util/mdds: Add IUSE=openmp (diff)
downloadgentoo-145fbf100e4f0e9d75f24b08f403dcc43137d2f8.tar.gz
gentoo-145fbf100e4f0e9d75f24b08f403dcc43137d2f8.tar.bz2
gentoo-145fbf100e4f0e9d75f24b08f403dcc43137d2f8.zip
dev-util/mdds: Fix bashisms in configure.ac
Reported-by: Matt Whitlock <gentoo@mattwhitlock.name> Closes: https://bugs.gentoo.org/723094 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mdds/files/mdds-1.6.0-bashism.patch75
-rw-r--r--dev-util/mdds/mdds-1.6.0.ebuild5
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-util/mdds/files/mdds-1.6.0-bashism.patch b/dev-util/mdds/files/mdds-1.6.0-bashism.patch
new file mode 100644
index 000000000000..4fa155c653fb
--- /dev/null
+++ b/dev-util/mdds/files/mdds-1.6.0-bashism.patch
@@ -0,0 +1,75 @@
+From 65da7c25f4d8204b1379a0afb46d82dc1b263ab0 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 28 May 2020 18:36:07 +0200
+Subject: [PATCH] Fix bashisms in configure.ac
+
+---
+ configure.ac | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 00ab937..2282165 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,7 +32,7 @@ AC_ARG_ENABLE(debug-stdcxx,
+ ]
+ ,debug_stdcxx=yes)
+
+-AS_IF([test x"$debug_stdcxx" == "xyes"], [
++AS_IF([test x"$debug_stdcxx" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -D_GLIBCXX_DEBUG"
+ ])
+
+@@ -42,7 +42,7 @@ AC_ARG_ENABLE(release-tests,
+ ]
+ ,release_tests=yes)
+
+-AS_IF([test x"$release_tests" == "xyes"], [
++AS_IF([test x"$release_tests" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -DNDEBUG -O2"
+ ])
+
+@@ -56,11 +56,11 @@ AC_ARG_ENABLE(loop-unrolling,
+ [enable_loop_unrolling="$enableval"],[enable_loop_unrolling=yes]
+ )
+
+-AS_IF([test x"$enable_loop_unrolling" == "xno"], [
++AS_IF([test x"$enable_loop_unrolling" = "xno"], [
+ CXXFLAGS="$CXXFLAGS -DMDDS_LOOP_UNROLLING=0"
+ ])
+
+-AS_IF([test x"$enable_gcov" == "xyes"], [
++AS_IF([test x"$enable_gcov" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS --coverage -O0"
+ ])
+
+@@ -69,7 +69,7 @@ AC_ARG_ENABLE(openmp,
+ [enable_openmp="$enableval"],[enable_openmp=yes]
+ )
+
+-AS_IF([test x"$enable_openmp" == "xyes"], [
++AS_IF([test x"$enable_openmp" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -fopenmp"
+ LDFLAGS="$LDFLAGS -fopenmp"
+ ])
+@@ -79,7 +79,7 @@ AC_ARG_ENABLE(sanitizer-coverage,
+ [enable_sanitizer_coverage="$enableval"],[enable_sanitizer_coverage=no]
+ )
+
+-AS_IF([test x"$enable_sanitizer_coverage" == "xyes"], [
++AS_IF([test x"$enable_sanitizer_coverage" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -fprofile-instr-generate -fcoverage-mapping -O0"
+ ])
+
+@@ -122,7 +122,7 @@ AC_ARG_ENABLE([werror],
+ [enable_werror="$enableval"],
+ [enable_werror=no]
+ )
+-AS_IF([test x"$enable_werror" == "xyes"], [
++AS_IF([test x"$enable_werror" = "xyes"], [
+ CXXFLAGS="$CXXFLAGS -Werror"
+ ])
+
+--
+2.26.2
+
diff --git a/dev-util/mdds/mdds-1.6.0.ebuild b/dev-util/mdds/mdds-1.6.0.ebuild
index a8ee00cd56bf..9364d50feb9a 100644
--- a/dev-util/mdds/mdds-1.6.0.ebuild
+++ b/dev-util/mdds/mdds-1.6.0.ebuild
@@ -30,7 +30,10 @@ BDEPEND="
DEPEND="dev-libs/boost:="
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-buildsystem.patch"
+ "${FILESDIR}/${P}-bashism.patch" # bug 723094
+)
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp