summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-18 19:09:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-18 22:58:02 +0200
commit15c0411827731a166c2e5634b73ae9fc77f599cc (patch)
tree8f8077aa539d65e880a0901456f640f9206ced0c /dev-util
parentdev-util/kdevelop: 5.3.3 version bump (diff)
downloadgentoo-15c0411827731a166c2e5634b73ae9fc77f599cc.tar.gz
gentoo-15c0411827731a166c2e5634b73ae9fc77f599cc.tar.bz2
gentoo-15c0411827731a166c2e5634b73ae9fc77f599cc.zip
dev-util/kdevelop-php: 5.3.3 version bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/kdevelop-php/Manifest1
-rw-r--r--dev-util/kdevelop-php/kdevelop-php-5.3.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/kdevelop-php/Manifest b/dev-util/kdevelop-php/Manifest
index d87e2026b8a2..6aaad908ec19 100644
--- a/dev-util/kdevelop-php/Manifest
+++ b/dev-util/kdevelop-php/Manifest
@@ -1 +1,2 @@
DIST kdev-php-5.3.2.tar.xz 1008036 BLAKE2B 33940afeeb7b8594f0dbf56e444ba05f9665c7e4c9bc1d55c9d6a5b85bd2e03a04db1b8f27d968d627e26cfa573a3da519bb1d0eb592dc784296c9db7ea1fad8 SHA512 d8649bca173eccc1aa6568715e5976beb762ad7a377adbdab8f55aad76176ca5c8d16477ec70fa231b5699105d2a827c2ffda1c4835419c670c561b4444605b4
+DIST kdev-php-5.3.3.tar.xz 1043652 BLAKE2B d181984e0c8c6b77502529dace0cb2b13afa417e98149a7caaf379fc5c27e64f7928c4232489a0e4b21af6500636a71b7217a56e500c367a579585dca6c447a9 SHA512 8a478e6170ed63ccd82822a5281abb63f70d959ae945b730d2d707efd104b0a3475a66ddb637f134d1eed90173342c1ecf42e7b15947b96c141e6228ef96a009
diff --git a/dev-util/kdevelop-php/kdevelop-php-5.3.3.ebuild b/dev-util/kdevelop-php/kdevelop-php-5.3.3.ebuild
new file mode 100644
index 000000000000..b4d5c4853d81
--- /dev/null
+++ b/dev-util/kdevelop-php/kdevelop-php-5.3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DOC_DIR="docs"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+KMNAME="kdev-php"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/kdevelop/${PV}/src/${KMNAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="PHP plugin for KDevelop"
+HOMEPAGE="https://www.kdevelop.org/"
+LICENSE="GPL-2 LGPL-2"
+IUSE=""
+
+BDEPEND="
+ test? ( dev-util/kdevelop:5[test] )
+"
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep threadweaver)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-util/kdevelop-pg-qt:5
+ dev-util/kdevelop:5
+"
+RDEPEND="${DEPEND}"
+
+# remaining tests fail for some, bug 668530
+RESTRICT+=" test"
+
+src_test() {
+ # tests hang, bug 667922
+ local myctestargs=(
+ -E "(completionbenchmark|duchain_multiplefiles)"
+ )
+ kde5_src_test
+}