summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-02 11:30:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-02 11:30:17 +0200
commit1a6f2e5afd53fa68b7a337e1da8c7ddb9aafa80e (patch)
treeb95676f9793825661dab57ace3d6e59be4cc0efa /dev-util
parentsys-apps/man-db: Synced live ebuild (diff)
downloadgentoo-1a6f2e5afd53fa68b7a337e1da8c7ddb9aafa80e.tar.gz
gentoo-1a6f2e5afd53fa68b7a337e1da8c7ddb9aafa80e.tar.bz2
gentoo-1a6f2e5afd53fa68b7a337e1da8c7ddb9aafa80e.zip
dev-util/strace: Bump to version 5.7
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-5.7.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index b6e409ce2080..d743c16faca0 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -2,3 +2,4 @@ DIST strace-5.3.tar.xz 1572708 BLAKE2B 808bc7afc6c70137c44d0f5a47706953bc7c02143
DIST strace-5.4.tar.xz 1599396 BLAKE2B 0a7fd9600488f5f07042ead8123151cf0113f82329c3cc786c8f3ffb8673f73eaaa1a489f1f27c47800a20e5b6327f1bf5fb09a5b798156908f9e10374a04970 SHA512 4ddba2ec4457a2257c18b26dca851e49a275813c4eb3069379a93fcc60228f9b63a3dee9e3719ae606a7cc61d55ab21ce147327223903c302c061e381097a8d7
DIST strace-5.5.tar.xz 1628744 BLAKE2B ae2ab9b2c756858c3c23640ee19821b8720da84a5e15e4a674768d8f4b51d74b2b490cfa18a862bc3c9d129baeaf09212700bea98ac151db035d03a05afa055d SHA512 317fe6341000b452cf038433c2a9a7bcdc8ce736e97b242673ce066dd9dbd3b2c3435a014b529429fdf2ac8af5c3a72d62971b293d007b7d3efcbb684c216231
DIST strace-5.6.tar.xz 1775292 BLAKE2B 6e674e4a1b70a3ebb28aa0097baa07efc7dce18039a3a7d535b4c8b3fc1b11c59ef1eb79e58bbf4b9e2b9621d0840958ba5785d22d0cdcb4c00fb5fa2a3288c1 SHA512 58c8a250e55a018206bee9468ea057c087d5d5bb523339ea3c01e0a19d8f84c95bd1398d66a6dca6ada45c6535aa44b776713a2bb080eebaa734ffb926ac5b38
+DIST strace-5.7.tar.xz 1805044 BLAKE2B 487a1481357642be21c83cf387710bc75f17bd0af87ff07f914faa99120a619f33d2caba034d50dbdbc03aa3f758dae86d04fc6c25b3f6254ac3f0578a19884a SHA512 aef481238196204495cf9507cd48ce30af799f79904478e6be57a267311a999c868f18540cc1e025f5e486730cfe9ccb256f528f6f796d204a7347ebdf2042f1
diff --git a/dev-util/strace/strace-5.7.ebuild b/dev-util/strace/strace-5.7.ebuild
new file mode 100644
index 000000000000..5d7d3277504a
--- /dev/null
+++ b/dev-util/strace/strace-5.7.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strace/strace.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="https://strace.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio perl static unwind elfutils"
+
+REQUIRED_USE="?? ( unwind elfutils )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+LIB_DEPEND="
+ unwind? ( sys-libs/libunwind[static-libs(+)] )
+ elfutils? ( dev-libs/elfutils[static-libs(+)] )
+"
+# strace only uses the header from libaio to decode structs
+DEPEND="
+ static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )
+"
+
+PATCHES=(
+ "${FILESDIR}/strace-5.5-static.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if [[ ! -e configure ]] ; then
+ # git generation
+ sed /autoreconf/d -i bootstrap || die
+ ./bootstrap || die
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+
+ export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
+
+ # Stub out the -k test since it's known to be flaky. #545812
+ sed -i '1iexit 77' tests*/strace-k.test || die
+}
+
+src_configure() {
+ # Set up the default build settings, and then use the names strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
+ # Don't require mpers support on non-multilib systems. #649560
+ local myeconfargs=(
+ --disable-gcc-Werror
+ --enable-mpers=check
+ $(use_enable static)
+ $(use_with unwind libunwind)
+ $(use_with elfutils libdw)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} ; then
+ ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
+ return 0
+ fi
+
+ default
+}
+
+src_install() {
+ default
+ if ! use perl ; then
+ rm "${ED}"/usr/bin/strace-graph || die
+ fi
+ dodoc CREDITS
+}