summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-27 21:36:55 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-27 22:08:27 +0200
commit1d64f1ca401dc71189df3f6338280f0573b52c13 (patch)
tree31690dce5c4613b430dabe33bf7c47d132c40134 /dev-util
parentdev-ml/core_bench: 0.15.0 bump (diff)
downloadgentoo-1d64f1ca401dc71189df3f6338280f0573b52c13.tar.gz
gentoo-1d64f1ca401dc71189df3f6338280f0573b52c13.tar.bz2
gentoo-1d64f1ca401dc71189df3f6338280f0573b52c13.zip
dev-util/intel-graphics-compiler: add 1.0.11061
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11061.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 6be5111d94d1..723f11295400 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,2 +1,3 @@
DIST intel-graphics-compiler-1.0.10778.tar.gz 8515512 BLAKE2B 56d7a0b54ce026d93179737fe199d006923398b7f85d582487469f1cfa665ae5351bc160c6babda5d8bf2bf6173a051277b2fb11c9ccf4b888cd0e06295161c4 SHA512 e8fcdab3a8c70f8560f49288db42a926f1e8e82d3e433bb897fcd1648acdf0f8fe425a1cd8dae5bfabc7d0a91fe0c985550e35c6396fe46778091852e185e750
DIST intel-graphics-compiler-1.0.10988.tar.gz 8571350 BLAKE2B 8f1fcba9016eb607de4604b152e559cae8547c99a618dfc533591165c2da95b466227b75c4ef2b2e9064ec0a30fac711176a7f46f2952df51c06e172fcdcffe4 SHA512 b4de7dc195ee089321a28a428e7604f187552ca161bd08ef245f61740f2ee91e8d48d0718dac17641368113cd8e92ec177a994622f3539dd307542e9dabf5663
+DIST intel-graphics-compiler-1.0.11061.tar.gz 8586132 BLAKE2B e8d97622c353e997acea1b9bed34423aaf0044a10d2effbe2c4b146ced1388ca5cf72ff1716e69d378625d674c09e84e7864b6817a0dfd0ba05a29de9f1aca6c SHA512 eb1688ff42c154267b82ffcc9fc58e587d7d52a8157cc8ca692e4d726eb62830fd3812bf391552d43e1d0c17c1ed59a6c3c206a35324c05a12ed943113f1a9d8
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11061.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11061.ebuild
new file mode 100644
index 000000000000..fc02ff9997b0
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11061.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+LLVM_MAX_SLOT="13"
+MY_PN="igc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake flag-o-matic llvm python-any-r1
+
+DESCRIPTION="LLVM-based OpenCL compiler for OpenCL targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/opencl-clang:${LLVM_MAX_SLOT}=
+ dev-util/spirv-tools
+ =sys-devel/lld-${LLVM_MAX_SLOT}*
+ sys-devel/llvm:${LLVM_MAX_SLOT}=
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ =sys-devel/lld-${LLVM_MAX_SLOT}*
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-no_Werror.patch"
+ "${FILESDIR}/${PN}-1.0.8173-opencl-clang_version.patch"
+ "${FILESDIR}/${PN}-1.0.8365-disable-git.patch"
+)
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # Get LLVM version
+ local llvm_version="$(best_version -d sys-devel/llvm:${LLVM_MAX_SLOT})"
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/212
+ append-ldflags -Wl,-z,undefs
+
+ # See https://bugs.gentoo.org/718824
+ ! use debug && append-cppflags -DNDEBUG
+
+ local mycmakeargs=(
+ -DCCLANG_SONAME_VERSION="${LLVM_MAX_SLOT}"
+ -DCMAKE_LIBRARY_PATH="$(get_llvm_prefix ${LLVM_MAX_SLOT})/$(get_libdir)"
+ -DIGC_OPTION__ARCHITECTURE_TARGET="Linux64"
+ -DIGC_OPTION__CLANG_MODE="Prebuilds"
+ -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR="ON"
+ -DIGC_OPTION__LLD_MODE="Prebuilds"
+ -DIGC_OPTION__LLDELF_H_DIR="${EPREFIX}/usr/include/lld/Common"
+ -DIGC_OPTION__LLVM_MODE="Prebuilds"
+ -DIGC_OPTION__LLVM_PREFERRED_VERSION="${llvm_version##*-}"
+ -DIGC_OPTION__SPIRV_TOOLS_MODE="Prebuilds"
+ -DIGC_OPTION__SPIRV_TRANSLATOR_MODE="Prebuilds"
+ -DIGC_OPTION__USE_PREINSTALLED_SPRIV_HEADERS="ON"
+ -DINSTALL_GENX_IR="ON"
+ -DSPIRVLLVMTranslator_INCLUDE_DIR="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/include/LLVMSPIRVLib"
+
+ # Compilation with VectorCompiler causes currently a segfault.
+ # See https://github.com/intel/intel-graphics-compiler/issues/236
+ -DIGC_BUILD__VC_ENABLED="OFF"
+ # -DIGC_OPTION__VC_INTRINSICS_MODE="Prebuilds"
+
+ # This will suspress some CMake warnings,
+ # which cannot be fixed at the moment.
+ -Wno-dev
+ )
+
+ cmake_src_configure
+}